Closed Bug 898781 Opened 6 years ago Closed 6 years ago

Opening new tab sometimes causes exceptions in WindowsPreviewPerTab.jsm

Categories

(SeaMonkey :: Tabbed Browser, defect)

defect
Not set

Tracking

(seamonkey2.21 fixed, seamonkey2.22 fixed, seamonkey2.23 fixed)

RESOLVED FIXED
seamonkey2.23
Tracking Status
seamonkey2.21 --- fixed
seamonkey2.22 --- fixed
seamonkey2.23 --- fixed

People

(Reporter: neil, Assigned: neil)

References

Details

Attachments

(1 file)

When (re)opening a tab, if it is not the rightmost tab, or if the new tab is to be selected (which is always true for undo close tab), then the tab events are dispatched in the wrong order and WindowsPreviewPerTab.jsm tries to move or select tabs that it doesn't know about yet. Bug 839891 copied bug 648101's original error in sending TabOpen at the wrong time (Firefox also sends it before the tab is moved into place).
Attached patch Proposed patchSplinter Review
[The wording I was looking for was foreground tab.]
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #782176 - Flags: review?(philip.chee)
Comment on attachment 782176 [details] [diff] [review]
Proposed patch

r=me
Attachment #782176 - Flags: review?(philip.chee) → review+
Comment on attachment 782176 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 648101/839891
User impact if declined: Probably not noticably user-visible
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #782176 - Flags: approval-comm-beta?
Attachment #782176 - Flags: approval-comm-aurora?
Attachment #782176 - Flags: approval-comm-aurora? → approval-comm-aurora+
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.23
Attachment #782176 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.