Closed Bug 898837 Opened 7 years ago Closed 7 years ago

Australis: Fix social-share-button CSS

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: Gijs, Assigned: mixedpuppy)

References

Details

(Whiteboard: [Australis:M9][Australis:P3])

Attachments

(1 file)

When merging bug 886816 I noticed our social CSS is a little mixed up... Someone already noted this in bug 875488 comment 79 and bug 875488 comment 80, but I was too busy/lazy to followup at the time.

Note in particular:

It's missing from shared/toolbarbuttons.inc.css (http://hg.mozilla.org/projects/ux/file/b0549e859d22/browser/themes/shared/toolbarbuttons.inc.css )

However:

http://hg.mozilla.org/projects/ux/file/b0549e859d22/browser/themes/osx/browser.css#l471

(wrong id?)

http://hg.mozilla.org/projects/ux/file/b0549e859d22/browser/themes/osx/browser.css#l903

(only in customization panel)

But then:

http://hg.mozilla.org/projects/ux/file/b0549e859d22/browser/themes/osx/browser.css#l1873

And I don't know which of these wins because I don't know how to get this button to show up.

Because of this, I've left the button in our copy of @primaryToolbarButtons@ for now, because for Australis it *should* be using the sprite sheet, I believe. But this should probably be fixed properly.

(Marking P3 because I don't think this is seen by every user, and it might be OK for the moment but can use cleaning up? In any case, this might be P2 if the impact were bigger / brokenness is very bad right now on UX (which I can't tell))
Blocks: 875488
No longer blocks: australis-cust
(In reply to :Gijs Kruitbosch from comment #0)

> http://hg.mozilla.org/projects/ux/file/b0549e859d22/browser/themes/osx/
> browser.css#l471
> 
> (wrong id?)

seems wrong, but I haven't looked at the xul for australis

> http://hg.mozilla.org/projects/ux/file/b0549e859d22/browser/themes/osx/
> browser.css#l903
> 
> (only in customization panel)
> 
> But then:
> 
> http://hg.mozilla.org/projects/ux/file/b0549e859d22/browser/themes/osx/
> browser.css#l1873

is this only from the merge?  If so, perhaps someone changed the share icon in australis already?

> And I don't know which of these wins because I don't know how to get this
> button to show up.

enable facebook or the sample provider at http://mixedpuppy.github.io/socialapi-demo/
Shane, can you take this?
Assignee: nobody → mixedpuppy
Status: NEW → ASSIGNED
Attached patch fix share cssSplinter Review
this fixes the css for the button on osx and windows.  The css and images on linux do not look like they've been updated.

I have only tested this on osx non-retina, someone needs to validate windows/retina before this gets committed.
Attachment #796848 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 796848 [details] [diff] [review]
fix share css

Review of attachment 796848 [details] [diff] [review]:
-----------------------------------------------------------------

The patch looks great to me, and it works on retina. I'll test Windows ASAP.
Attachment #796848 - Flags: review?(gijskruitbosch+bugs) → review+
This looks fine on Windows, too. If you have a tree, please land away and mark the whiteboard as [Australis:M9][Australis:P3][fixed-in-ux]. If not, no worries, I'll do it in ~9-10 hours. :-)
Landed: https://hg.mozilla.org/projects/ux/rev/efd952ce34f8
Whiteboard: [Australis:P3] → [Australis:M9][Australis:P3][fixed-in-ux]
(In reply to :Gijs Kruitbosch from comment #6)
> Landed: https://hg.mozilla.org/projects/ux/rev/efd952ce34f8

Err, I meant https://hg.mozilla.org/projects/ux/rev/660f552f8160 . Oops!
Duplicate of this bug: 874773
https://hg.mozilla.org/mozilla-central/rev/660f552f8160
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M9][Australis:P3][fixed-in-ux] → [Australis:M9][Australis:P3]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.