crash in mozilla::gl::BasicTextureImage::~BasicTextureImage @ OpenGL@0x32af

VERIFIED FIXED in Firefox 27

Status

()

--
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: scoobidiver, Assigned: mstange)

Tracking

({crash, regression})

25 Branch
mozilla27
x86_64
Mac OS X
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox24 unaffected, firefox25 wontfix, firefox26 wontfix, firefox27 verified)

Details

(crash signature)

(Reporter)

Description

5 years ago
With the below stack trace, it first showed up in 25.0a1/20130725. The regression range might be (low volume):
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2983ca6d4d1a&tochange=a4c1961bf723
It's likely a regression from bug 858914.

A comment says: "uploaded to imgur"

Signature 	OpenGL@0x32af More Reports Search
UUID 	66e8716c-db48-4d76-81b9-4e9a82130728
Date Processed	2013-07-28 16:47:49.995108
Uptime	16328
Last Crash	70361 seconds before submission
Install Age 	70353 since version was first installed.
Install Time 	2013-07-27 21:15:11
Product 	Firefox
Version 	25.0a1
Build ID 	20130727030206
Release Channel 	nightly
OS 	Mac OS X
OS Version 	10.8.4 12E55
Build Architecture 	amd64
Build Architecture Info 	family 6 model 42 stepping 7 | 8
Crash Reason 	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash Address 	0xffffffff87797f20
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x 126GL Layers! GL Context? GL Context+ GL Layers+ 

Frame 	Module 	Signature 	Source
0 	OpenGL 	OpenGL@0x32af 	
1 	OpenGL 	OpenGL@0xc226 	
2 	AppKit 	AppKit@0x67481 	
3 	XUL 	mozilla::gl::GLContextCGL::MakeCurrentImpl(bool) 	gfx/gl/GLContextProviderCGL.mm
4 	XUL 	mozilla::gl::BasicTextureImage::~BasicTextureImage() 	gfx/gl/GLContext.h
5 	XUL 	mozilla::gl::BasicTextureImage::~BasicTextureImage() 	gfx/gl/GLTextureImage.cpp
6 	XUL 	mozilla::layers::TextureImageDeprecatedTextureHostOGL::SetCompositor(mozilla::layers::Compositor*) 	obj-firefox/x86_64/dist/include/GLTextureImage.h
7 	XUL 	mozilla::layers::ContentHostBase::SetCompositor(mozilla::layers::Compositor*) 	gfx/layers/composite/ContentHost.cpp
8 	XUL 	mozilla::layers::PCompositableParent::OnMessageReceived(IPC::Message const&) 	obj-firefox/x86_64/ipc/ipdl/PCompositableParent.cpp
9 	XUL 	mozilla::layers::PCompositorParent::OnMessageReceived(IPC::Message const&) 	obj-firefox/x86_64/ipc/ipdl/PCompositorParent.cpp
10 	XUL 	mozilla::ipc::AsyncChannel::OnDispatchMessage(IPC::Message const&) 	ipc/glue/AsyncChannel.cpp
11 	XUL 	mozilla::ipc::RPCChannel::OnMaybeDequeueOne() 	ipc/glue/RPCChannel.cpp
12 	XUL 	MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&) 	/builds/slave/m-in-osx64-0000000000000000000/build/obj-firefox/x86_64/ipc/chromium/../../../../ipc/chromium/src/base/message_loop.cc
13 	XUL 	MessageLoop::DoWork() 	/builds/slave/m-in-osx64-0000000000000000000/build/obj-firefox/x86_64/ipc/chromium/../../../../ipc/chromium/src/base/message_loop.cc
14 	XUL 	base::MessagePumpDefault::Run(base::MessagePump::Delegate*) 	/builds/slave/m-in-osx64-0000000000000000000/build/obj-firefox/x86_64/ipc/chromium/../../../../ipc/chromium/src/base/message_pump_default.cc
15 	XUL 	MessageLoop::Run() 	/builds/slave/m-in-osx64-0000000000000000000/build/obj-firefox/x86_64/ipc/chromium/../../../../ipc/chromium/src/base/message_loop.cc
16 	XUL 	base::Thread::ThreadMain() 	ipc/chromium/src/base/thread.cc
17 	XUL 	ThreadFunc 	/builds/slave/m-in-osx64-0000000000000000000/build/obj-firefox/x86_64/ipc/chromium/../../../../ipc/chromium/src/base/platform_thread_posix.cc
18 	libsystem_c.dylib 	libsystem_c.dylib@0x147a2 	
19 	libsystem_c.dylib 	libsystem_c.dylib@0x11e1 	
20 	XUL 	XUL@0x758c00

More reports at:
https://crash-stats.mozilla.com/report/list?product=Firefox&signature=OpenGL%400x32af
I doubt this is a regression from bug 858914 because at the moment only naming changes have landed from this bug.
It looks like the kind of crashes we have when a GL resource (like a texture) is used after we destroyed the GL context (which at least on Linux, not sure about OSX) goes away along with the widget.

Updated

5 years ago
No longer blocks: 858914
Depends on: 929506
(Assignee)

Comment 2

5 years ago
This was fixed by one or more patches in this push (probably those from bug 914437): https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=30c25c68bb3e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 914437
Resolution: --- → FIXED
Assignee: nobody → mstange
status-firefox25: affected → wontfix
status-firefox26: --- → wontfix
status-firefox27: --- → fixed
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.