[B2G] [Leo] [Bluetooth] Unable to send files over Bluetooth

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Bluetooth
VERIFIED WORKSFORME
4 years ago
4 years ago

People

(Reporter: CKreinbring, Unassigned)

Tracking

({regression, smoketest})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 782666 [details]
Log of attempt to send file via Bluetooth

Description:
Attempting to send a file to another device via Bluetooth will result in the sending user receiving an error message and no file transfer taking place.

Repro Steps:
1) Update Leo to Build ID: 20130729070226
2) Pair the device with another via Bluetooth.
3) Select Gallery then a picture.
4) Tap the Share button (second from the right) then Bluetooth Transfer.
5) Select the paired device if it's not selected already then tap OK.
6) Observe the device's reaction.

Actual:
Error message appears stating "Bluetooth file transfer failed.  Check that the Bluetooth settings are correct."

Expected:
The receiving device shows a prompt asking the user if they want to download the sent file.

Environmental Variables
Occurs on Leo 1.1 mozilla RIL
Build ID: 20130729070226
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8135299f3efd
Gaia: 7aaffc8ccb6cf7ddd1e97943c108f1cb9eae5de0
Platform Version: 18.1

Notes:
Repro frequency: 2 out of 3 devices failed.
See attached screenshot and logcat logs
(Reporter)

Comment 1

4 years ago
Created attachment 782667 [details]
Screenshot of error message

Updated

4 years ago
blocking-b2g: --- → leo?

Updated

4 years ago
Keywords: regression
Haven't yet been able to reproduce this on Leo using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/8135299f3efd
Gaia   7aaffc8ccb6cf7ddd1e97943c108f1cb9eae5de0
BuildID 20130729070226
Version 18.1

I was able to transfer a music file from Leo device to Buri device.

It would be helpful to clarify which devices are failing.
(Reporter)

Comment 3

4 years ago
I just did more testing on today's mozilla RIL build, and I was able to transfer files between the Leo and an Unagi (1.1 mozilla RIL).  However, attempting to transfer files between two Leos failed every time.

Build ID: 20130730070228
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/1fe3339e3d96
Gaia: 6221737cb50d6e8435ac5d3fe3b7e2788bd8a37c
Platform Version: 18.1
Does the issue happened on leo devices only? If yes, I would like to guess platform issue.
(In reply to Ian Liu [:ianliu] from comment #4)
> Does the issue happened on leo devices only? If yes, I would like to guess
> platform issue.

QA Wanted for comment 4. Can someone try reproducing this bug on a device different than leo? unagi or buri would work here.
Keywords: qawanted
Also is this a partner build ?

Comment 7

4 years ago
The issue no longer reproduces on 7/31 Leo build
 - able to transfer images via BT back and forth between Leo and Unagi
 - able to transfer images via BT back and forth between two Leo devices

Build ID: 20130731070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/aff662053ee8
Gaia: 6c635e809baedb6b3393bd351b8ce95304782ac6
Platform Version: 18.1

resolving as works for me, please reopen if the issue reoccurs
Status: NEW → RESOLVED
blocking-b2g: leo? → ---
Last Resolved: 4 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

4 years ago
Still able to share files with other device over Bluetooth on Leo 1.1 commerical RIL.  Verifying as Worksforme.

Build ID: 20130807071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/11bb1b0eefff
Gaia: 60ca81600a080dae33058b0692ecaa213556c926
Platform Version: 18.1
RIL Version: 01.01.00.019.184
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.