Closed Bug 899508 Opened 6 years ago Closed 6 years ago

[Helix] Firefox OS boot up splash(blue one) is not in full screen.

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:hd+, b2g-v1.1hd affected)

VERIFIED DUPLICATE of bug 898256
blocking-b2g hd+
Tracking Status
b2g-v1.1hd --- affected

People

(Reporter: echu, Assigned: amylee)

References

Details

(Whiteboard: helix vsd, HD)

Attachments

(4 files)

Attached image picture
Please check attached picture, there are black space on top and bottom of it.

* Build Number                
Gaia:     f2bc4a004f592cd6dce4edda2b0533f4fd4f91f2
  B-D     2013-07-25 18:32:32
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/2bb08f2878da
BuildID   20130725070202
Version   18.1

* Reproduce Steps
Check the last boot up splash screen during boot process.

* Expected Result
Full mode as the orange one.

* Actual Result
Not in full mode.
blocking-b2g: --- → hd?
Marco, is this displayed by system? Can we update this to full screen?

HD+ asset bug
blocking-b2g: hd? → hd+
Flags: needinfo?(mchen)
Gecko had a bootanimiation component which is used to show Gecko's splash screen. so we can check it.
Flags: needinfo?(mchen)
Hi Wayne,

The picture used for boot animation is 320 * 420, we may need the new picture size for Helix screen size. This needs UX's help. Thanks. 

https://github.com/mozilla-b2g/gonk-misc/blob/master/bootanimation.zip
Flags: needinfo?(wchang)
Assign to Amy at request to Patryk.
Assignee: nobody → amylee.design
Flags: needinfo?(wchang)
Whiteboard: helix vsd
Hi Michael,

https://docs.google.com/a/mozilla.com/file/d/0BxKpB0y8NZSHYkxfbkNrTGF3UTA/edit?usp=sharing
(please use mozilla account to download it.)

This is used by 1.1.0hd and it's screen size is 480 * 800. So we got the correct pictures from UX guys then update it here.

Could you help to review then I will update it to gonk-misc (1.1.0hd branch)?
Flags: needinfo?(mwu)
Hi

Barry (brand's motion graphics guy) is providing the boot animation on a separate thread.
Here is the bug for your reference:
https://bugzilla.mozilla.org/show_bug.cgi?id=896622
Depends on: 896622
(In reply to Amy from comment #6)
> Hi
> 
> Barry (brand's motion graphics guy) is providing the boot animation on a
> separate thread.

Hi Amy,

The bootanimation I used here is from the Barry's mail indeed.
And I want to clarify that the bug 896622 mentioned the image of recovery mode not boot animation. Maybe you mix them together.
Hi Marco, 

I was responding to comment #3 above. I don't have permission to see bug 896622.
I added you into 896622 already. Thanks.
adding status-b2g-v1.1hd:? flag
Thanks for your help!

I cannot reproduce this bug on following build.
I will test it again after the patch uplift to V1.1.0 HD
* Test build:(Mozilla-b2g18_v1_1_0_hd-helix/2013-08-12-04-22-03)
  + Mercurial-Information
    - Gecko revision="afd50da34b9f"
  + Git-information
    - Gaia revision="134356dc21d0627455f8bc536b140a18f39e20e9"

By the way, if you need to align Firefox OS icon to the center.
Please reopen the bug.
Thanks!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Attached image IMG_0002.jpg
Status: RESOLVED → VERIFIED
(In reply to William Hsu [:whsu] from comment #11)
> Thanks for your help!
> 
> I cannot reproduce this bug on following build.
> I will test it again after the patch uplift to V1.1.0 HD
> * Test build:(Mozilla-b2g18_v1_1_0_hd-helix/2013-08-12-04-22-03)
>   + Mercurial-Information
>     - Gecko revision="afd50da34b9f"
>   + Git-information
>     - Gaia revision="134356dc21d0627455f8bc536b140a18f39e20e9"
> 
> By the way, if you need to align Firefox OS icon to the center.
> Please reopen the bug.
> Thanks!

Hi William,

I think we should center the Firefox logo.  The reason I believe it should be centered is because the Huawei and Firefox boot logos are both centered before it.  Will a new image asset be needed for this? Let me know, thanks!
Hi, Eric,

Thanks for your suggestion and help.
I would follow your idea because you are the expert on the UI design.
Please center the Firefox logo.

I change the status to "REOPENED" to mark this case.
If you change your mind, please change the status to "VERIFIED"
Thanks!
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Thanks William!  I've attached the centered screen.
Hi Marco, can you update to the new screen?
Flags: needinfo?(mchen)
Hi Evelyn,

The attached (https://bug899508.bugzilla.mozilla.org/attachment.cgi?id=792126) seems to be shown by Gaia (replacing powered by mozilla) not Gecko (boot animation only). Could you help to check this?
Flags: needinfo?(mwu)
Flags: needinfo?(mchen)
Flags: needinfo?(ehung)
Whiteboard: helix vsd → helix vsd, HD
Hi Evelyn, will you be able to update the blue splash screen today?
Gary can help this.
Flags: needinfo?(ehung) → needinfo?(gchen)
It seems this image existed on master branch.
I will cherry-pick into HD branch and comment on bug 898256.
https://github.com/mozilla-b2g/gaia/blob/master/shared/resources/branding/official/initlogo%401.5x.png
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?(gchen)
Resolution: --- → DUPLICATE
Duplicate of bug: 898256
(In reply to GaryChen [:GaryChen] from comment #20)
> It seems this image existed on master branch.
> I will cherry-pick into HD branch and comment on bug 898256.
> https://github.com/mozilla-b2g/gaia/blob/master/shared/resources/branding/
> official/initlogo%401.5x.png
> 
> *** This bug has been marked as a duplicate of bug 898256 ***

Thanks Gary!
Hi, all,

I cannot reproduce this case on latest vendor build.
Marked it as verified.
* Test Build:(Vendor Build)
 - Gaia:     "2a20910ea96efb538ec0c99ff25a540ed641f63f"
 - Gecko:    ""
 - BuildID   20130923135853
 - Version   18.0
Status: RESOLVED → VERIFIED
Resolution: DUPLICATE → FIXED
This should remain as a dupe, but should just be moved to verified.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 898256
Attached image Boot screen - Helix
You need to log in before you can comment on or make changes to this bug.