[FIG] The url and the title text are overlapped on Gingerbread and lower devices

RESOLVED FIXED in Firefox 26

Status

()

Firefox for Android
General
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: AdrianT, Assigned: lucasr)

Tracking

({regression})

Trunk
Firefox 26
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed-fig])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 783124 [details]
screenshot

LG Optimus 2X (Android 2.2)/ Samsung Galaxy R (Android 2.3)
Fig Nightly 2013-07-29

Steps to reproduce:
1) Open the app and tap on the URL bar
2) Enter any text in the url bar

Expected results:
The user can enter text

Actual results:
The text input field and the title bar are overlapped. This is not reproducible with the 2013-07-24 build but that build crashes
(Assignee)

Updated

5 years ago
Priority: -- → P1
(Reporter)

Comment 1

5 years ago
Actually the build were the url is correctly displayed but the build crashes is 2013-07-26
Duplicate of this bug: 903062
(Assignee)

Updated

5 years ago
Assignee: nobody → lucasr.at.mozilla
(Assignee)

Comment 3

5 years ago
Created attachment 790167 [details] [diff] [review]
Disable editing mode animations on pre-Honeycomb devices
Attachment #790167 - Flags: review?(sriram)
(Assignee)

Comment 4

5 years ago
FYI: the equivalent animation is disabled in m-c. This patch simply applies the same behaviour on the new code.
Comment on attachment 790167 [details] [diff] [review]
Disable editing mode animations on pre-Honeycomb devices

Review of attachment 790167 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good to me. But why would be need to disable alpha animations on GB?
Attachment #790167 - Flags: review?(sriram) → review+
(Assignee)

Comment 6

5 years ago
(In reply to Sriram Ramasubramanian [:sriram] from comment #5)
> Comment on attachment 790167 [details] [diff] [review]
> Disable editing mode animations on pre-Honeycomb devices
> 
> Review of attachment 790167 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> This looks good to me. But why would be need to disable alpha animations on
> GB?

Because the alpha animation is meant to run in sync with the animation to expand the URL bar. With this change, the URL bar simply snaps to the expanded size. So, the about:home UI should just snap on screen too.
(Assignee)

Comment 7

5 years ago
Pushed: http://hg.mozilla.org/projects/fig/rev/5b87508c0148
Whiteboard: [fixed-fig]

Comment 8

5 years ago
https://hg.mozilla.org/mozilla-central/rev/5b87508c0148
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
You need to log in before you can comment on or make changes to this bug.