Closed Bug 899735 Opened 6 years ago Closed 6 years ago

IonMonkey: Add a function to the shell that makes it possible to bail in IM

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25

People

(Reporter: h4writer, Assigned: h4writer)

References

Details

Attachments

(1 file)

In bug 891910 I disable a "common" way to bailout. This is needed for some testcases. So I'm adding a bailout() function in the shell for this.
Blocks: 891910
Assignee: general → hv1989
Attachment #783314 - Flags: review?(jdemooij)
Comment on attachment 783314 [details] [diff] [review]
bug899735-bail-func

Review of attachment 783314 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #783314 - Flags: review+
Comment on attachment 783314 [details] [diff] [review]
bug899735-bail-func

Review of attachment 783314 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.

::: js/src/ion/LIR-Common.h
@@ +1022,5 @@
> +  public:
> +    LIR_HEADER(Bail)
> +
> +    LBail()
> +    { }

Nit: can remove the empty constructor.

::: js/src/ion/MIR.h
@@ +1570,5 @@
> +class MBail : public MNullaryInstruction
> +{
> +  protected:
> +    MBail()
> +    { }

Nit: this instruction is effectful so won't be removed, but maybe call setGuard(); just to make sure it won't be removed when somebody marks it as non-effectful (we should probably do this now by overriding getAliasSet).
Attachment #783314 - Flags: review?(jdemooij) → review+
https://hg.mozilla.org/mozilla-central/rev/8d0d262985d9
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Duplicate of this bug: 736315
You need to log in before you can comment on or make changes to this bug.