Closed Bug 899863 Opened 6 years ago Closed 6 years ago

ChannelMediaResource should treat resources with a Content-Length as finite

Categories

(Core :: Audio/Video, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26
Tracking Status
firefox25 --- fixed
firefox26 --- fixed

People

(Reporter: roc, Assigned: roc)

References

Details

Attachments

(1 file)

In bug 619752, we talked about treating resources with a Content-Length as finite, but the patch only checks the Content-Duration header (and its aliases). This means when the channel does not support range requests (which includes a Necko response!), and the resource doesn't have a Content-Duration header, we report its duration as infinite (even if we successfully decode a duration from the container).
I meant "Necko cache response".
Attachment #783493 - Flags: review?(cpearce) → review+
https://hg.mozilla.org/mozilla-central/rev/e14729d47ea8
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Comment on attachment 783493 [details] [diff] [review]
Ensure resources with a Content-Length (that's not the result of a range request) are treated as bounded

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: none, probably; but needed for Web Audio to work on Aurora
Testing completed (on m-c, etc.): been on m-c for a week or so
Risk to taking this patch (and alternatives if risky): pretty low risk
String or IDL/UUID changes made by this patch: none
Attachment #783493 - Flags: approval-mozilla-aurora?
Approval ping? This is blocking a bunch of WebAudio patches to be landed on Aurora.
Flags: needinfo?(lsblakk)
(In reply to Paul Adenot (:padenot) from comment #6)
> Approval ping? This is blocking a bunch of WebAudio patches to be landed on
> Aurora.

Ping?
Flags: needinfo?(release-mgmt)
Comment on attachment 783493 [details] [diff] [review]
Ensure resources with a Content-Length (that's not the result of a range request) are treated as bounded

Apologies, at a Stability work week and behind on approvals.
Attachment #783493 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/61cbf67c2fc4
Flags: needinfo?(release-mgmt)
Flags: needinfo?(lsblakk)
You need to log in before you can comment on or make changes to this bug.