Test failure "Addons have been found - got 'false'" in /testAddons/testSearchAddons.js

RESOLVED FIXED

Status

Mozilla QA
Mozmill Tests
P1
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Andrei Eftimie, Assigned: AndreeaMatei)

Tracking

unspecified

Firefox Tracking Flags

(firefox27 wontfix, firefox31 fixed, firefox32 fixed, firefox33 fixed, firefox34 fixed, firefox-esr31 fixed)

Details

(Whiteboard: [mozmill-test-failure][mozmill-remote], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Test:      testSearchAddons    
Failure:   Addons have been found - got 'false'
Branches:  23
Platforms: OSX

We have 1 failure on Beta (23), en-US on OSX:
http://mozmill-release.blargon7.com/#/remote/report/b3aefd29a5c41bda1cc43616d3aecacb
This may have been a temporary issue with AMO. It hasn't recurred in over a week, so I'm going to close as WORKSFORME. Please reopen if this issue comes back.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

4 years ago
We're still seeing an occasional failure, like:
http://mozmill-daily.blargon7.com/#/remote/report/837c1e0f361ac93453ee69721976b55a

Might very well be connectivity problems with AMO.

Since this test is a remote one now, we can't track it in the dashboard :(
I'll reopen it right now, lets see when its failing again.
Status: RESOLVED → REOPENED
status-firefox27: --- → affected
OS: Mac OS X → All
Priority: -- → P3
Resolution: WORKSFORME → ---
It failed again on Mac 10.7.5 with Release de:
http://mozmill-release.blargon7.com/#/remote/report/0bbed480c5898d9d02bca5d17985628e
It failed on:
mac 10.7, 10.8 and 10.9 with esr_24.3 and 26.0(release)
I couldn't reproduce it, being a remote test it might been an issue with AMO.
Failed again with Aurora en-US on Windows xp x86 (mm-win-xp-32-3)
http://mozmill-daily.blargon7.com/#/remote/report/16dc29d7a411d565992bbd7dc82db56b
(Reporter)

Comment 6

4 years ago
http://mozmill-daily.blargon7.com/#/remote/failure?app=All&branch=All&platform=All&from=2014-05-05&test=%2FtestAddons%2FtestSearchAddons.js&func=testSearchAddons

Failed several times on Aurora 31 yesterday. All during a 1 hour period. All on Ubuntu.
Not reproducible.
status-firefox27: affected → wontfix
status-firefox31: --- → affected
Keywords: intermittent-failure
(Assignee)

Comment 7

3 years ago
This is failing again for Beta and Aurora so far, several locales. Might be a network issue, looking to reproduce now:
http://mozmill-daily.blargon7.com/#/remote/failure?app=Firefox&branch=33.0&platform=All&from=2014-08-19&to=&test=%2FtestAddons%2FtestSearchAddons.js&func=testSearchAddons

http://mozmill-release.blargon7.com/#/remote/failure?app=Firefox&branch=32.0&platform=All&from=2014-08-19&to=&test=%2FtestAddons%2FtestSearchAddons.js&func=testSearchAddons
(Assignee)

Updated

3 years ago
status-firefox32: --- → affected
status-firefox33: --- → affected
(Assignee)

Comment 8

3 years ago
I can reproduce this locally by running the mozmill test with Beta and Aurora. After searching for rss, no addons are retrieved. Will look further.
Assignee: nobody → andreea.matei
Status: REOPENED → ASSIGNED
Priority: P3 → P1
(Assignee)

Comment 9

3 years ago
https://addons-dev.allizom.org/ is down. I'll add a skip patch just in case it takes longer to fix.
(Assignee)

Comment 10

3 years ago
Created attachment 8475116 [details] [diff] [review]
skip.patch

Disabling patch.
Attachment #8475116 - Flags: review?(andrei.eftimie)
(Reporter)

Comment 11

3 years ago
Comment on attachment 8475116 [details] [diff] [review]
skip.patch

Review of attachment 8475116 [details] [diff] [review]:
-----------------------------------------------------------------

Disabled:
https://hg.mozilla.org/qa/mozmill-tests/rev/667ce2a60961 (default)
https://hg.mozilla.org/qa/mozmill-tests/rev/10d6029a1624 (mozilla-aurora)
Attachment #8475116 - Flags: review?(andrei.eftimie)
Attachment #8475116 - Flags: review+
Attachment #8475116 - Flags: checkin+
(Reporter)

Updated

3 years ago
status-firefox33: affected → disabled
status-firefox34: --- → disabled
(Reporter)

Comment 12

3 years ago
Transplanted:
https://hg.mozilla.org/qa/mozmill-tests/rev/cd5eb193a659 (mozilla-beta)
https://hg.mozilla.org/qa/mozmill-tests/rev/c89e3dd97427 (mozilla-release)
https://hg.mozilla.org/qa/mozmill-tests/rev/75f04cf08dc1 (mozilla-31)
status-firefox31: affected → disabled
status-firefox32: affected → disabled
status-firefox-esr31: --- → disabled
Whiteboard: [mozmill-test-failure][mozmill-remote] → [mozmill-test-failure][mozmill-remote][mozmill-test-skipped]
(Reporter)

Comment 13

3 years ago
All this is caused by an outage of the addons-dev server as tracked in bug 1055509
Depends on: 1055509
(Reporter)

Comment 14

3 years ago
The underlying issue has been fixed.

Backed out skip:
https://hg.mozilla.org/qa/mozmill-tests/rev/d4a44193b095 (default)
https://hg.mozilla.org/qa/mozmill-tests/rev/ef062c97da97 (mozilla-aurora)
https://hg.mozilla.org/qa/mozmill-tests/rev/295fa1fe73a2 (mozilla-beta)
https://hg.mozilla.org/qa/mozmill-tests/rev/7e886131f900 (mozilla-release)
https://hg.mozilla.org/qa/mozmill-tests/rev/a587070dd60f (mozilla-esr31)
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago3 years ago
status-firefox31: disabled → fixed
status-firefox32: disabled → fixed
status-firefox33: disabled → fixed
status-firefox34: disabled → fixed
status-firefox-esr31: disabled → fixed
Keywords: intermittent-failure
Resolution: --- → FIXED
Whiteboard: [mozmill-test-failure][mozmill-remote][mozmill-test-skipped] → [mozmill-test-failure][mozmill-remote]
Problems like those concern me a lot! So I filed bug 1058445 to get rid of the dev server but use the production or staging one.
You need to log in before you can comment on or make changes to this bug.