Console injected objects don't inherit from window objects

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Nicolas FROIDURE, Unassigned)

Tracking

22 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 783858 [details]
index.html

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.63 Safari/537.31

Steps to reproduce:

We used a project named Jasper to create a small contest but it appeared to be impossible for Firefox users to play with it.

The user had to create a String object, pass it to a function declared in the window scope who test if the object was inheriting from String (obj instanceof String).


Actual results:

The function in the window scope does not recognize that the object has been build with the String constructor.


Expected results:

The function should recognize the object a a string.

I suggest you to give a quick look to the attached file to better understand.

Comment 1

5 years ago
Works for Me in Firefox23b10
http://hg.mozilla.org/releases/mozilla-beta/rev/0e3cb8907fef
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 ID:20130729175331

This maybe fixed by Bug 783499

Updated

5 years ago
Attachment #783858 - Attachment mime type: text/plain → text/html

Comment 2

5 years ago
false false false: 2013-04-09-03-08-55-mozilla-central-firefox-23.0a1.ru.linux-x86_64
true true true: 2013-04-10-06-59-39-mozilla-central-firefox-23.0a1.en-US.linux-x86_64

Comment 3

5 years ago
Closing per comment 1 and comment 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Depends on: 783499
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.