app:// URI scheme conformance

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: marcosc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
The following errors were reported to me about the app:// URI scheme... 
[[

Test suite: https://github.com/sysapps/testsuites/tree/gh-pages/app-URI
Tested on: FF OS simulator version 4.0 updated 19-07-2013
 
Errors I’ve found during testing app-URI test suite:
1.       Content-Type is always application/xml – is that by design? TC:  “Test: [HTTP] 200 reponse status (OK),value of content-type as the [HTTP]”
2.       Error 501 – I get 200 while I should get 501. When I pass request XHR with “gett”  method I expect to get 501 error – in FFos simulator actually I get 200 – is that by design? Do you correct XHR requests?  
3.       Error 400
a.       I get 200 while I should get 400 – I used only domain (no path to specific file) something like:  app://f15a6d20-cefa-13e5-1972-800e20d19a76 how I get 200 for that? I think this is an error.
b.      I get “Access to restricted URI denied” when asked file from different domain with not path also, but this response does not come as response from XHR. I believe it should go through XHR response while it is terminated by the system.
4.       Error 403 – I get “Access to restricted URI denied” when asked file from different domain, but this response does not come as response from XHR. I believe it should go through XHR response while it is terminated by the system.
5.       Error 404 – I get “File error: Not found” but this response does not come as response from XHR. I believe it should go through XHR response while it is terminated by the system.
]]

Still need to go through them and verify them.
(Reporter)

Comment 1

4 years ago
Not aiming for standards compliance with this spec.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.