If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G] [Unagi] [v1.2] [Notifications] User does not get visual or sound notifications on device.

RESOLVED FIXED

Status

Firefox OS
Gaia::System
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Nick Davidson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 784014 [details]
notifications not working-log.txt

Description:
When user receives SMS/MMS, Bluetooth transfer file, System update, or takes a screenshot he does not receive visual or sound notification of completed action. 

Repro Steps:
1) Updated Unagi to Build ID: 20130731030205
2) Send several SMS to the device
3) Pair with other device via Bluetooth And receive Bluetooth transfer from other device. 
4)Take a screenshot on a device.

Actual:
User does not get visual(banner on a top) or sound notifications on device.
Expected:
User should get notification banner with sound notification every time he performs actions described in repro steps.

Environmental Variables
Build ID: 20130731030205
Gecko: http://hg.mozilla.org/mozilla-central/rev/c2b375f3a909
Gaia: 9bfceaa90e8b92a379432b67121afa3cd3f14c90
Platform Version: 25.0a1

Notes:
Repro frequency: 100%, 
See attached:  logcat 
Optional extra notes: When taking screenshots device vibrates, this is only notification indicating screenshot is taken.
I'm pretty sure this was caused by https://github.com/mozilla-b2g/gaia/commit/359b76d47ad2694c7237332797b818c3f5b0e53b.

John - Can you back that out?
Flags: needinfo?(jhford)
Actually, hold off for a second. Let's confirm this the patch to back out.
Flags: needinfo?(jhford)
disregard comment 2 - We're good to back out https://github.com/mozilla-b2g/gaia/commit/359b76d47ad2694c7237332797b818c3f5b0e53b.
Fixed by backout in https://github.com/mozilla-b2g/gaia/commit/715d314bbfa7a06315213ffbae923c15999689ea.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Kyle Machulis added a comment in Pivotal Tracker:   
   
This was fixed via a backout before anyone could get to it. Doesn't look like there's a way to mark that though. So does this just become "finished" with 0 points?
Candice Serran deleted the linked story in Pivotal Tracker
You need to log in before you can comment on or make changes to this bug.