Closed Bug 900373 Opened 9 years ago Closed 8 years ago

Callout missing on YouTube's Statistics

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: simona.marcu, Unassigned)

References

()

Details

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130731 Firefox/25.0

Steps to reproduce:
1. Launch Firefox 
2. Navigate to YouTube and search for a video that has the Statistics disabled
http://www.youtube.com/watch?v=uGthVEza97U&feature=player_detailpage
http://www.youtube.com/watch?v=OTx8LPszHEI
3. Hover the mouse over the statistics icon

Expected results:
A callout saying that "Stats have been disabled for this video"  is displayed above the Statistics icon.

Actual results:
A tooltip saying that "Stats have been disabled for this video" is displayed instead of a callout.
If the statistics are not disabled, the proper callout is displayed when hovering the icon.
Please see the screencast for more details:
http://screencast.com/t/uZKUMpvqJqq

Notes:
The issue is reproducible on the latest Nightly, the latest Aurora, Firefox 22RC, Firefox 23RC and ever since Firefox 4.0.1.
The issue is not reproducible on Opera 15.0.1147.141 and on Chrome 28.0.1500.72.
Severity: normal → minor
Please also check Internet Explorer so we have a comparison across different rendering engines (Opera and Chrome both use WebKit).
I did a quick comparison and here are the results:
 * Chrome: "Stats disabled" flyout appears
 * Firefox: "Stats disabled" tooltip appears
 * IE: "Stats disabled" flyout flickers and quickly disappears

I think this is yet another case of Youtube designing for Webkit. If you can show evidence that we have a bug in Firefox then please move this back to Core Layout.
Assignee: nobody → english-us
Severity: minor → trivial
Component: Layout → English US
Product: Core → Tech Evangelism
I have the feeling the UI of YouTube has changed since the report of this bug. Basically Statistics Icon is there only if the stats are available.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 8 years ago
Component: English US → Desktop
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.