crash in `anonymous namespace''::handle_channel_layout

RESOLVED FIXED in mozilla26

Status

()

Core
Audio/Video
--
critical
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Scoobidiver (away), Assigned: padenot)

Tracking

({crash, regression})

25 Branch
mozilla26
All
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(firefox24 unaffected, firefox25 affected)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
It first showed up in 25.0a1/20130730. Based on the stack trace, it's likely a regression from bug 893307 that landed two builds earlier.

Signature 	`anonymous namespace''::handle_channel_layout More Reports Search
UUID 	5657e07e-5c4a-4f98-a463-c1c282130731
Date Processed	2013-07-31 21:05:23.365649
Uptime	120
Last Crash	138 seconds before submission
Install Age 	717 since version was first installed.
Install Time 	2013-07-31 20:12:48
Product 	Firefox
Version 	25.0a1
Build ID 	20130731030203
Release Channel 	nightly
OS 	Windows NT
OS Version 	6.2.9200
Build Architecture 	x86
Build Architecture Info 	GenuineIntel family 6 model 30 stepping 5 | 8
Crash Reason 	EXCEPTION_ACCESS_VIOLATION_WRITE
Crash Address 	0x661acd7c
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x68c1, AdapterSubsysID: 1448103c, AdapterDriverVersion: 12.104.0.0
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 

Frame 	Module 	Signature 	Source
0 	gkmedias.dll 	`anonymous namespace'::handle_channel_layout 	media/libcubeb/src/cubeb_wasapi.cpp
1 	gkmedias.dll 	`anonymous namespace'::wasapi_stream_init(cubeb *,cubeb_stream * *,char const *,cubeb_stream_params,unsigned int,long (*)(cubeb_stream *,void *,void *,long),void (*)(cubeb_stream *,void *,cubeb_state),void *) 	media/libcubeb/src/cubeb_wasapi.cpp
2 	gkmedias.dll 	cubeb_stream_init 	media/libcubeb/src/cubeb.c
3 	xul.dll 	mozilla::BufferedAudioStream::Init(int,int,mozilla::dom::AudioChannelType) 	content/media/AudioStream.cpp
4 	xul.dll 	mozilla::MediaDecoderStateMachine::AudioLoop() 	content/media/MediaDecoderStateMachine.cpp
5 	xul.dll 	nsRunnableMethodImpl<void ( mozilla::dom::DOMStorageDBThread::*)(void),0>::Run() 	obj-firefox/dist/include/nsThreadUtils.h
6 	xul.dll 	nsThread::ProcessNextEvent(bool,bool *) 	xpcom/threads/nsThread.cpp
7 	xul.dll 	nsThread::ThreadFunc(void *) 	xpcom/threads/nsThread.cpp
8 	nss3.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c
9 	nss3.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c
10 	msvcr100.dll 	_callthreadstartex 	f:\\dd\\vctools\\crt_bld\\self_x86\\crt\\src\\threadex.c
11 	msvcr100.dll 	_threadstartex 	f:\\dd\\vctools\\crt_bld\\self_x86\\crt\\src\\threadex.c
12 	kernel32.dll 	BaseThreadInitThunk 	
13 	ntdll.dll 	__RtlUserThreadStart 	
14 	ntdll.dll 	_RtlUserThreadStart

More reports at:
https://crash-stats.mozilla.com/report/list?product=Firefox&signature=%60anonymous+namespace%27%27%3A%3Ahandle_channel_layout
(Assignee)

Updated

4 years ago
Assignee: nobody → paul
(Assignee)

Comment 1

4 years ago
Created attachment 786313 [details] [diff] [review]
wasapi-formattag
Attachment #786313 - Flags: review?(kinetik)
(Assignee)

Updated

4 years ago
Attachment #786313 - Attachment is patch: true
Comment on attachment 786313 [details] [diff] [review]
wasapi-formattag

Review of attachment 786313 [details] [diff] [review]:
-----------------------------------------------------------------

Out of curiosity, what other values have you seen for wFormatTag in this case?
Attachment #786313 - Flags: review?(kinetik) → review+
(Assignee)

Comment 3

4 years ago
I could not repro myself, but it would make sense to have WAVE_FORMAT_PCM.
(Assignee)

Comment 4

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f74f1e59dc50
(Assignee)

Comment 5

4 years ago
This is fixed. There are still recent crashes, but I checked, and it is because people haven't updated their Nightlies.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

4 years ago
It's not fixed on Aurora 25.
Target Milestone: --- → mozilla26
(Assignee)

Comment 7

4 years ago
Yes, I've received uplift approval (the commit that fixed this bug was a library update that fixed three bugs, I've asked in another bug), I'll land that shortly.
You need to log in before you can comment on or make changes to this bug.