Closed Bug 900414 Opened 6 years ago Closed 4 years ago

Dragged and dropped text from a HTML page to webmail is pasted in Chinese

Categories

(Core :: Editor, defect)

13 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 586587

People

(Reporter: mihaelav, Unassigned)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached image screenshot.jpg
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

When you drag and drop text from webpages opened in other browsers into emails (webmail providers as Yahoo, Gmail) edited in Firefox, the pasted text is in Chinese characters (and is not related to the source text).

Steps to reproduce:
1. Log in to your webmail accout (yahoo, gmail) using Firefox
2. Start composing a new email
3. Select text from a page opened in Chrome/Opera
4. Drag the selected text and drop it as the content of the email

Expected result: text should be correctly copied and pasted into the email content

Actual result: text is pasted with Chinese characters

Notes:
1. The issue is not a Firefox 23 regression (it is also reproducible on Firefox 22)
2. The issue is not reproducible on Firefox 4.0
3. The issue is reproducible on Windows (8.1, 7, XP) and Ubuntu (13.04), but it is not reproducible on Mac (10.8.3)
4. The issue is not reproducible with text dragged from Thunderbird emails, other Firefox windows or Yahoo Messenger conversations
5. The issue is not reproducible with copy-paste
STR
1. Open http://www-archive.mozilla.org/editor/midasdemo/
2. Open Chrome and Open any web page (ex. https://developer.mozilla.org/En/Code_snippets/Tabbed_browser)
3. Select text (ex "Tabbed Browser") in Chrome
4. Drag &Drop the selected text to Ritch Text editor of Step1

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/a3b93f3949fe
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120217 Firefox/13.0a1 ID:20120217155649
Bad:
http://hg.mozilla.org/mozilla-central/rev/e001b5eda618
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1 ID:20120217162149
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a3b93f3949fe&tochange=e001b5eda618


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/174ce0df7cdd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1 ID:20120217061753
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/51d333edddfd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1 ID:20120217062249
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=174ce0df7cdd&tochange=51d333edddfd


Regressed by: Bug 499008
Blocks: 499008
Keywords: regression
Version: unspecified → 13 Branch
Component: General → Editor
Attached file dragtypes.html
I don't see this bug. Can you try opening the attached page, and dropping the same text into the box, then pasting the text that gets output here?

Are you using a non-english browser/locale for either browser?
Attached image 無題.png
(In reply to Neil Deakin from comment #2)
> Created attachment 784360 [details]
> dragtypes.html
> 
> I don't see this bug. Can you try opening the attached page, and dropping
> the same text into the box, then pasting the text that gets output here?
> 

See attached screenshot and paste the followings results
------------------------------
 Items: 1 Item 0: text/html: (string) : <格‱汣獡㵳瀢条ⵥ楴汴≥猠祴敬∽慭杲湩›瀰㭸瀠摡楤杮›瀰⁸瀰⁸瀰⁸㠱硰※潦瑮猭穩㩥ㄠ㠮㜵浥※楷瑤㩨㔠㌸㘮ㄷ㜸瀵㭸挠汯牯›杲⡢ㄵㄵㄵ㬩映湯⵴慦業祬›䰧捵摩⁡片湡敤Ⱗ✠界楣慤匠湡⁳湕捩摯❥䐧橥噡⁵慓獮Ⱗ䰠捵摩ⱡ䄠楲污效癬瑥捩ⱡ猠湡⵳敳楲㭦映湯⵴瑳汹㩥渠牯慭㭬映湯⵴慶楲湡㩴渠牯慭㭬氠瑥整⵲灳捡湩㩧渠牯慭㭬漠灲慨獮›畡潴※整瑸愭楬湧›瑳牡㭴琠硥⵴湩敤瑮›瀰㭸琠硥⵴牴湡晳牯㩭渠湯㭥眠楨整猭慰散›潮浲污※楷潤獷›畡潴※潷摲猭慰楣杮›瀰㭸ⴠ敷止瑩琭硥⵴瑳潲敫眭摩桴›瀰㭸戠捡杫潲湵ⵤ潣潬㩲爠执㈨㘴㐲ⰶ㈠ㄴ㬩㸢慔扢摥戠潲獷牥⼼ㅨ>> text/plain: (string) : <Tabbed browser> 
--------------------------------

> Are you using a non-english browser/locale for either browser?

Chrome28.0.1500.95m
Firefox12
Nightly25.0a1
All English version
The problem is reproduced in Firefox2.0-25.0a1 on ubuntu12.04(I did not check Firefox1.5 and earlier)

So, The regression range of comment#1 is only for windows.
Upon thinking about this further, I'm wondering if this is a Chrome or WebKit bug. So far I'm only seeing evidence that this happens when dragging *from* a WebKit browser *to* Firefox. What happens when you do this from Firefox to Chrome? How about from Chrome to other applications? How about IE to Firefox?
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #5)
> Upon thinking about this further, I'm wondering if this is a Chrome or
> WebKit bug. So far I'm only seeing evidence that this happens when dragging
> *from* a WebKit browser *to* Firefox. What happens when you do this from
> Firefox to Chrome? How about from Chrome to other applications? How about IE
> to Firefox?

Drag&drop from Firefox to Chrome - OK
Drag&drop from IE to Firefox - OK
Drag&drop from IE/Chrome/Firefox to other application (wordpad)- OK

Mozilla/5.0 (Windows NT 6.0; rv:28.0) Gecko/20100101 Firefox/28.0 (20131030030201)
Dropping markup from Chrome to Firefox still produces these weird results. We've faced this issue while testing drag&drop integration.

I'm assuming that issue should be within FF, since drop to IE works as expected. In addition Mihaela mentioned that this issue was not reproducible with FF4 (at Windows).

All the tests made with FF29, UA: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0.

Dropping from Chrome to IE8 works fine.

Dn from IE to FF can't be tested, since FF does not accept dropping content from IE - tested with IE8 and IE11. (Though e.g. IE11 accepts dropped markup from FF).
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 586587
You need to log in before you can comment on or make changes to this bug.