Button labels in the panel menu are too small

RESOLVED FIXED in Firefox 29

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: dao, Assigned: Gijs)

Tracking

(Blocks: 1 bug, {access})

Trunk
Firefox 29
access
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P2][good first verify])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
The button labels in the panel menu are ridiculously small, certainly small enough that users with poor eye sight won't be able to read them. We should either:

- Stop reducing the text size. This might cause labels to be cut off earlier, but they're only an additional hint anyway.

- Remove the labels. They aren't there for buttons placed on the toolbar. (There was an option for that, but we removed it.) If icons aren't distinctive enough, we should fix them. Tooltips are still there as additional hints.
Tooltips aren't keyboard accessible for non-mouse users, though.
(Reporter)

Comment 2

5 years ago
Well, I said "additional hint", because the primary hint should really be the icon.

Plus, we have a menu bar for proper keyboard access. If you're serious about making the panel menu a first-class keyboard access target (making it work for sub views, items that spawn menus and other randomly-structured widgets sounds like it should be a fun project...), I guess this leaves us with the option to use the standard size for UI text.
Whiteboard: [Australis:M?] → [Australis:M?][Australis:P?]
Keywords: uiwanted
Whiteboard: [Australis:M?][Australis:P?] → [Australis:M?][Australis:P4]

Comment 3

5 years ago
Note that the bookmarks widget label is already bigger than the others.
I'd like to know what, if anything, we should be doing here. Note that the panel labels are extra-small on Linux currently (compared to Windows/OS X). I'm not sure if there's anything else that should be done.
Flags: needinfo?(shorlander)
(In reply to :Gijs Kruitbosch from comment #4)
> I'd like to know what, if anything, we should be doing here. Note that the
> panel labels are extra-small on Linux currently (compared to Windows/OS X).
> I'm not sure if there's anything else that should be done.

The labels are small, but not too small, on OS X and Windows. This seems Linux specific. Although the labels in the footer are much larger. Can we just match that size for the rest of the items?
Flags: needinfo?(shorlander)
(Reporter)

Comment 6

5 years ago
(In reply to Stephen Horlander [:shorlander] from comment #5)
> (In reply to :Gijs Kruitbosch from comment #4)
> > I'd like to know what, if anything, we should be doing here. Note that the
> > panel labels are extra-small on Linux currently (compared to Windows/OS X).
> > I'm not sure if there's anything else that should be done.
> 
> The labels are small, but not too small, on OS X and Windows.

Based on what rule, data, etc.? I can't speak for OS X, but on Windows the font size is smaller than for any other UI text I can find. It also seems obvious to me that this will affect people with suboptimal eyesight who need to run Windows at 125% in order to make _normal_ text (which we're undercutting here) legible. Am I missing something?
(In reply to Dão Gottwald [:dao] from comment #6)
> (In reply to Stephen Horlander [:shorlander] from comment #5)
> > (In reply to :Gijs Kruitbosch from comment #4)
> > > I'd like to know what, if anything, we should be doing here. Note that the
> > > panel labels are extra-small on Linux currently (compared to Windows/OS X).
> > > I'm not sure if there's anything else that should be done.
> > 
> > The labels are small, but not too small, on OS X and Windows.
> 
> Based on what rule, data, etc.? I can't speak for OS X, but on Windows the
> font size is smaller than for any other UI text I can find. It also seems
> obvious to me that this will affect people with suboptimal eyesight who need
> to run Windows at 125% in order to make _normal_ text (which we're
> undercutting here) legible. Am I missing something?

You are right. I didn't look closely enough on Windows. On OS X the difference is not so stark. Likely due to font rendering differences. I will dig a little deeper and figure out a recommendation.
(Reporter)

Updated

5 years ago
Whiteboard: [Australis:M?][Australis:P4] → [Australis:M?][Australis:P2]
Assignee: nobody → shorlander
Duplicate of this bug: 939864
Just to note: the font size in the panel menu is currently fixed at 10px throughout OSes. The perceived difference is solely because of context and/or the actual font family and/or display used being more or less legible at that size.

Ubuntu uses "Ubuntu" font and it's pretty much completely illegible - especially when compared to the default menu and url bar font size of 14.6px (on my VM, at least).

Mac uses "Lucida Grande", which is readable for me (on my retina screen), although less so since bug 941095 is still waiting to be backed out / fixed / whatever it is. The urlbar uses 12px. Tabs use bold 11px.

Windows uses "Segoe UI", which isn't very readable for me, but better than Ubuntu. The urlbar, the menubar and the tabs all use 12px.

Stephen, can we "just" use the 'regular' text size here instead, or did you want to propose something else?
Flags: needinfo?(shorlander)
(Reporter)

Comment 10

4 years ago
(In reply to :Gijs Kruitbosch from comment #9)
> Just to note: the font size in the panel menu is currently fixed at 10px
> throughout OSes. The perceived difference is solely because of context
> and/or the actual font family and/or display used being more or less legible
> at that size.
> 
> Ubuntu uses "Ubuntu" font and it's pretty much completely illegible -
> especially when compared to the default menu and url bar font size of 14.6px
> (on my VM, at least).
> 
> Mac uses "Lucida Grande", which is readable for me (on my retina screen),
> although less so since bug 941095 is still waiting to be backed out / fixed
> / whatever it is. The urlbar uses 12px. Tabs use bold 11px.
> 
> Windows uses "Segoe UI", which isn't very readable for me, but better than
> Ubuntu. The urlbar, the menubar and the tabs all use 12px.
> 
> Stephen, can we "just" use the 'regular' text size here instead, or did you
> want to propose something else?

That's bug 900428.
So, the plan from talking to Stephen is to use em and make it come out at about 11px on Windows/Mac, and see what that ends up meaning on Linux. I'll take this.
Assignee: shorlander → gijskruitbosch+bugs
Flags: needinfo?(shorlander)
Stephen is looking at the impact of switching to 11px on Mac, which causes more labels to wrap.
Flags: needinfo?(shorlander)
I have a patch for this from Stephen that I need to tweak.
Flags: needinfo?(shorlander) → needinfo?(gijskruitbosch+bugs)
Whiteboard: [Australis:M?][Australis:P2] → [Australis:M?][Australis:P2][maybe-fix-on-aurora]
Whiteboard: [Australis:M?][Australis:P2][maybe-fix-on-aurora] → [Australis:M?][Australis:P2][can-fix-on-aurora]
Status: NEW → ASSIGNED
Flags: needinfo?(gijskruitbosch+bugs)
Keywords: uiwanted
Whiteboard: [Australis:M?][Australis:P2][can-fix-on-aurora] → [Australis:P2]
Created attachment 8362940 [details] [diff] [review]
Increase Menu Panel Label Font-Size,

This is essentially the patch Stephen gave me, with some tweaks to use defines so it's obvious what certain values (7em for individual items) relate to.
Attachment #8362940 - Flags: review?(jaws)
Comment on attachment 8362940 [details] [diff] [review]
Increase Menu Panel Label Font-Size,

Review of attachment 8362940 [details] [diff] [review]:
-----------------------------------------------------------------

r+ but it would be cool if we can use `rem` for the font-size here.
Attachment #8362940 - Flags: review?(jaws) → review+
Landed with rem,

remote:   https://hg.mozilla.org/integration/fx-team/rev/f59607697038
Whiteboard: [Australis:P2] → [Australis:P2][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/f59607697038
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][fixed-in-fx-team] → [Australis:P2]
Target Milestone: --- → Firefox 29
(Reporter)

Updated

4 years ago
Depends on: 962620

Updated

4 years ago
Depends on: 962855

Updated

4 years ago
Whiteboard: [Australis:P2] → [Australis:P2][good first verify]
You need to log in before you can comment on or make changes to this bug.