Last Comment Bug 900776 - Trace actor reports NaN time when exiting frames
: Trace actor reports NaN time when exiting frames
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: Firefox 25
Assigned To: Jake Bailey
:
:
Mentors:
Depends on:
Blocks: 887024
  Show dependency treegraph
 
Reported: 2013-08-01 17:39 PDT by Jake Bailey
Modified: 2013-08-05 01:11 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (54.91 KB, patch)
2013-08-01 17:41 PDT, Jake Bailey
no flags Details | Diff | Splinter Review
exitTime.diff (3.23 KB, patch)
2013-08-01 17:49 PDT, Jake Bailey
nfitzgerald: review+
Details | Diff | Splinter Review

Description Jake Bailey 2013-08-01 17:39:37 PDT
When exiting a frame, the trace actor reports that the time since the trace started is NaN. It should report the time in the same format as it does on frame entry (currently, milliseconds since tracing started).
Comment 1 Jake Bailey 2013-08-01 17:41:29 PDT
Created attachment 784698 [details] [diff] [review]
Patch
Comment 2 Jake Bailey 2013-08-01 17:49:07 PDT
Created attachment 784702 [details] [diff] [review]
exitTime.diff

Whoops, generated the patch wrong.
Comment 3 Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2013-08-01 19:56:33 PDT
Comment on attachment 784702 [details] [diff] [review]
exitTime.diff

Review of attachment 784702 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with green try push[0]

In the future, format your patches with 8 lines of context[1].

[0] https://wiki.mozilla.org/ReleaseEngineering/TryServer#How_to_push_to_try

[1] https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F
Comment 4 Jake Bailey 2013-08-02 08:29:44 PDT
Try push: https://tbpl.mozilla.org/?tree=Try&rev=97c8bc7f176b
Comment 5 Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2013-08-02 17:28:16 PDT
https://hg.mozilla.org/integration/fx-team/rev/24446c5f75c1
Comment 6 Tim Taubert [:ttaubert] 2013-08-05 01:11:18 PDT
https://hg.mozilla.org/mozilla-central/rev/24446c5f75c1

Note You need to log in before you can comment on or make changes to this bug.