copying from textareas eats leading whitespace.

VERIFIED DUPLICATE of bug 86450

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 86450
17 years ago
17 years ago

People

(Reporter: Anthony Baxter, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Take a textarea with content with leading whitespace. 
Select the text. Paste the text. Notice that the leading
whitespace is not copied. 

Using xcb (xcutbuffer) I can see that mozilla's not putting 
the leading whitespace in the selection. Naughty Mozilla.

This breaks using the textarea to edit PythonScripts in Zope, as
well as anything else where you care about spacing (e.g. editing
plain text emails).
(Reporter)

Comment 1

17 years ago
Created attachment 41725 [details]
sample form demonstrating the problem.
Duplicate of "pasting plaintext into text area loses significant whitespace"

by way of bug 69024 ("Copy text from a textarea drops starting spaces")

*** This bug has been marked as a duplicate of 86450 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.