Buttons and some forms looks funky in Firefox for Android

RESOLVED DUPLICATE of bug 763671

Status

()

defect
RESOLVED DUPLICATE of bug 763671
6 years ago
6 years ago

People

(Reporter: u475305, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.95 Safari/537.36

Steps to reproduce:

Every button, textarea and input without background-image styling looks funky. Look at https://github.com/twbs/bootstrap/issues/8702. @ssoralen fixed that.


Actual results:

Everything look better with @ssoralen's fix.
The styling as shown in the screenshots on that issue is intentional. Closing as wontfix unless you have a good argument against.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Comment 2

6 years ago
What's the good argument in favour of introducing a default UA style that is not set by any other UA?
We're actually working on improving these in bug 763671, so I'm going to dup this there. But there isn't a standard style for this. The goals there are

1.) To not break web content. That involves doing some work to be compatible with other UA's (the bug is actually hung while I try to figure out a right way to do that) and
2.) To make something that looks good.

I don't feel like anyone has done such a good job on form styles that we're going to tie ourselves to reproducing their work exactly though.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 763671

Comment 4

6 years ago
Sure, as long as you're aware that normalize.css and Bootstrap are both fielding issues that developers are reporting to remove the styles that Firefox for Android is introducing – gradient background images, new borders around elements, etc.
You need to log in before you can comment on or make changes to this bug.