Handle state change: "CALL_STATE_DIALING" -> "CALL_STATE_CONNECTED"

RESOLVED FIXED in Firefox 26

Status

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: echou, Assigned: ben.tian)

Tracking

unspecified
1.1 QE5
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+, firefox24 wontfix, firefox25 wontfix, firefox26 fixed, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

Details

Attachments

(2 attachments)

I tried to answer a phone call while a Bluetooth headset was connected, but I found that my Unagi would not send indicator "Call=1" even if the call has been picked up. 

The root cause is that Gecko Blueooth received the CallStateChanged event which indicates the phone call state was changed from 'CALL_STATE_DIALING' to 'CALL_STATE_CONNECTED'. This is not what we expected. The state should be changed as

  CALL_STATE_DIALING -> CALL_STATE_ALERTING -> CALL_STATE_CONNECTED

I've talked to RIL peer HsinYi, and she will help us to confirm RIL implementation and GSM spec.
Reporter

Updated

6 years ago
Summary: Handle state change: "CALL_STATE_DIALING" - → Handle state change: "CALL_STATE_DIALING" - "CALL_STATE_CONNECTED
Reporter

Updated

6 years ago
Summary: Handle state change: "CALL_STATE_DIALING" - "CALL_STATE_CONNECTED → Handle state change: "CALL_STATE_DIALING" -> "CALL_STATE_CONNECTED"
Reporter

Comment 1

6 years ago
I'm sorry that I accidentally paste the wrong description above. Below is the correct description:

Based on bug 900882 comment 2, Gecko Bluetooth should handle call state change: CALL_STATE_DIALING -> CALL_STATE_CONNECTED, or the wrong state may confuse the user because of  the weird behavior of Bluetooth headset like the unreasonable LED flashing.
Reporter

Updated

6 years ago
Assignee: nobody → btian
Reporter

Comment 2

6 years ago
Nominate as leo+ since it would be very likely to happen on b2g18. Additionally, the solution won't be too complicated, so it should be harmless.
blocking-b2g: --- → leo?
Reporter

Comment 4

6 years ago
Comment on attachment 785614 [details] [diff] [review]
Patch 1: v1: Handle call state DIALING -> CONNECTED

Review of attachment 785614 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. Please note that this patch is m-c only, which means that it's not compatible with b2g18 codebase. We will need another patch if this bug becomes leo+ afterwards.
Attachment #785614 - Flags: review?(echou) → review+
Triage - leo+ as likely required for BT accessories to function correctly.
blocking-b2g: leo? → leo+
https://hg.mozilla.org/mozilla-central/rev/981444a82ce0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Reporter

Updated

6 years ago
Blocks: 897894

Comment 11

6 years ago
Verified fixed on 

Build ID: 20130814041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/15813d776a69
Gaia: dd3959fa74e356a528daa76ffee14c2c728a4b56
Platform Version: 18.1
RIL Version: 01.01.00.019.190 

User is able to answer phone call with Bluetooth successfully and no strange indicators shown

Updated

6 years ago
You need to log in before you can comment on or make changes to this bug.