[Peak] Back camera does not take photos in full resolution : 1.2M instead of 8M pixels

RESOLVED FIXED

Status

Firefox OS
Gaia::Camera
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Mossroy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 785378 [details]
Photo taken by my Peak device with back camera

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130627185035

Steps to reproduce:

Open the camera application and take a picture with the default camera (back)


Actual results:

The resolution of the photo is only 960 x 1280 pixels (~1.2M pixels). See attached file


Expected results:

Based on the specs of the Peak device from Geeksphone, the resolution should be of 8M pixels
The front camera has the expected resolution : 1200 x 1600 pixels (~2M pixels)
I'm using the stable image (1.0.1-prerelease 20130613185731) and I have this issue from the very beginning
(Reporter)

Updated

4 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM

Comment 1

4 years ago
I have a Peak device and confirm this behavior.

Comment 2

4 years ago
I have a Firefox Phone and I can confirm the same behavior.
I also have a Peak and I confirm this behaviour as well.

Comment 4

4 years ago
I confirm this issue. No option is available to change the quality of the picture.

Comment 5

4 years ago
Confirmed on my Peak.

Comment 6

4 years ago
I use a alcatel one touch fire and supposedly according to the manufacturer's camera is 3.2 Megapixel and should take photos at a resolution of 2048 x 1536 pixels and at this time I take pictures to 320x426 pixels so that leaves much to be desired: (

Comment 7

4 years ago
Confirmed the issue accuracy and relevance.

Comment 8

4 years ago
The issue reported in Geeksphone forum http://forum.geeksphone.com/index.php?topic=5176.0
(Reporter)

Comment 9

4 years ago
A side-effect of this issue is that it's very difficult to scan QR Codes (using any of the available applications for that)
Only very big QR codes are able to be interpreted because (I suppose) the photo is not precise enough

I see this issue still has the status "unconfirmed", despite all the people who confirmed it. What else should we do to update this status?

Comment 10

4 years ago
(In reply to Mossroy from comment #9)
> What else should we do to update this status?
You can vote for the issue to increase its priority. Unfortunately Bugzilla lets to vote just for one Boot2Gecko issue.

Comment 11

4 years ago
This seems like a major issue to me, especially for commercial Firefox OS phones. Any news?

Comment 12

4 years ago
This is not a Peak problem, it's the way that the application works and a switch of resolutions is a feature that will be in the future, but not now. If anyone wants to open another bug asking for this feature, feel free to do it. So please, close it as wont fix.

Comment 13

4 years ago
(In reply to Geeksphone from comment #12)
> This is not a Peak problem ...
Of course it is a Peak problem since the issue it related to it too.

Comment 14

4 years ago
Of course it's a PEAK bug. I unlocked the software limitation, took a photo at 3MP and the phone will block. See this post: http://forum.geeksphone.com/index.php?topic=5176.msg60363#msg60363
(Reporter)

Comment 15

4 years ago
Geeksphone,

How can you sell phones with a "8MP back camera" in the product spec, and consider this issue as "won't fix"?
How can you say it's not a Peak problem, when the Keon CAN have a higher resolution : its photos are 2MP (1200x1600) when the Peak only has 1.2MP (960x1280).
If it was only a limitation of the photo application, wouldn't it be the same limitation for the Keon?

I bought a developer phone : I'm OK to suffer from temporary bugs, and to wait a bit for some advanced features.
But you can't sell devices with some specs, and then tell us you will not work on making these capabilities usable in a near future

Comment 16

4 years ago
I agree with Mossroy.

Comment 17

4 years ago
I will try to reply all your questions.

First, the camera sensor in the Peak has 8Mp, maybe the drivers or the applicacion dont let you take photos at this resolution by now, but it has this resolution.

Second, this is the Mozilla bugtracker and the photo application dont let you take photos with more resolution, so this is not a Peak problem, it's a generic device application "problem". So a bug to Mozilla will not help you if you want to change other thing that is not the application.

Third, FirefoxOS only support the resolutions that its application supports and we only support this resolutions. When the photo application let you select other applications and you can select 8Mp resolutions, if our drivers or anything in the device dont let you take photos at this resolution, then you could open a bug and it will be addressed if we dont change it before this happens as we do with several other things. 

Anyway, as I explain this will be working in the future and i never said "tell us you will not work on making these capabilities usable in a near future".

I know that in our forums are a thread about this, but if you like you can open a new one (not technical) to discuss this.

Comment 18

4 years ago
But you already been told that this is the case. Me and others already unlocked the camera application (it's a simple software limitation) and we took photos to a bigger resolution. And, as I pointed out in a previous post, it is a driver problem. Please see this post before saying that it's not your problem: http://forum.geeksphone.com/index.php?topic=5176.msg60363#msg60363

So once again, we know that there is a software limitation. Probably this is why the guys handling Gaia put this software limitation. They knew that the Peak cannot take pictures to a bigger resolution, and being in a hurry to launch the phone, they put a software limitation. 

Anyway, we eliminated the software limitation. That was the easy part. 

Please also see this post, which suggest clearly that this is a driver problem: https://bugzilla.mozilla.org/show_bug.cgi?id=844921

Please have a look into it. 

Thank you.

Comment 19

4 years ago
When i speak about driver problem there is not so simple as it seems. The problem with the camera resolution is a mix between gecko and the way it sends resolutions to the camera. We can prove it, because when we use our android images with the same drivers the camera works flawessly at 8Mp.

If you fixed the application to be able to make photos at bigger resolution, please send this patch to Mozilla so they can upload it to their servers. Once it get uploaded, if it works in all other devices but the Peak, then you can open a bug.

And please, open a thread in the forum to discuss this.

Comment 20

4 years ago
There is a thread open for this in the geeksphone forum (http://forum.geeksphone.com/index.php?topic=5176.0). Are you referring to another forum?

Comment 21

4 years ago
Yes, this forum. If you like we can continue discussing there. But as you can see in this same thread (http://forum.geeksphone.com/index.php?topic=5176.msg60691#msg60691) in Android is working ok and it uses the same libraries and drivers.

Comment 22

4 years ago
There is the same problem with the Nexus 4 : 1,2M instead of 8M pixels

Comment 23

4 years ago
@vinilox:

Yes, this is true, but this is due to a software limitation. The question is, if you eliminate that limitation, will it work? Anyway, I can confirm that I've just installed the system mentioned in http://forum.geeksphone.com/index.php?topic=5176.0 and with Android on Peak, the camera works perfectly at 5MP. But also, I've tried (by recompiling the gaia webcam application and eliminating the software limitation) to take with the same device (Peak) a picture at 5MP and I encountered the blocking mentioned in this post: https://bugzilla.mozilla.org/show_bug.cgi?id=844921

So, to me this is a driver problem.

Comment 24

4 years ago
@Cosmin Hum yes you are right thanks for the info ! :)

Comment 25

4 years ago
Well, in the end it doesn't really matter where the bug sits - in FirefoxOS, in the driver or in the camera app. These three pieces must work together or the camera performance will stay seriously under par - and the camera is one of the most important features on smartphones today.

The Peak is the official developer phone for FirefoxOS and the camera should at least work in a way that does not look like mobile shots from 2007 ;-)

Comment 26

4 years ago
More than 2mp defined on camera= I/GeckoDump(  573): XXX FIXME : Got a mozContentEvent: permission-deny
less or 2mp define on camera, works as expected.

We can say that we have an Android firmware developed by us to compare the camera functionality with the same drivers, and we can take a picture with 8mp perfectly. Is not a driver issue. 
As i said before, with more than 2mp we have this message on the logcat: I/GeckoDump(  573): XXX FIXME : Got a mozContentEvent: permission-deny

Regards.

Comment 27

4 years ago
I would very much be interested in the driver binary that you are using. Is the driver currently existing on the phone? I've just updated this morning to the latest 1.1. Is it this driver? If not, could you please let us know how we can take the binaries? Maybe you can upload the binaries here? 

Thank you.

Comment 28

4 years ago
(In reply to Cosmin Popescu from comment #27)
> I would very much be interested in the driver binary that you are using. Is
> the driver currently existing on the phone? I've just updated this morning
> to the latest 1.1. Is it this driver? If not, could you please let us know
> how we can take the binaries? Maybe you can upload the binaries here? 
> 
> Thank you.

The binaries are on the latest 1.1

/system/lib
    libmmcamera_faceproc.so
    libmmcamera_frameproc.so
    libmmcamera_hdr_lib.so
    libmmcamera_image_stab.so
    libmmcamera_statsproc31.so
    libmmcamera_wavelet_lib.so
    libchromatix_s5k3h2y_default_video.so
    libchromatix_s5k3h2y_preview.so
    libchromatix_gc0339_default_video.so
    libchromatix_gc0339_preview.so
    libmmjpeg.so
    libmmstillomx.so
    libmmcamera_interface2.so
    libimage-jpeg-enc-omx-comp.so

/system/lib/hw
    camera.msm7627a.so

/system/bin
    mm-qcamera-daemon

I'm not sure if i missed someone.

Regards.

Comment 29

4 years ago
Yes missed liboemcamera.so

Comment 30

4 years ago
Thank you very much.

Comment 31

4 years ago
I guess a few of you will already know but to bring everybody up2date:
In the newer builds of Firefox OS 1.1 (including the latest dated 22. October 2013) the Geeksphone Peak is not able to take photos anymore. While shooting the photo the app gets stuck. Video works though.

Comment 32

4 years ago
I can confirm this. But since it's not a driver problem (the driver used on firefox OS is identical with the one used in android), then the problem lies in higher in the gonk layer? I would like to compile everything and solve the bug myself (if possible). But my problem is the 64bit architecture. Is it really necessary to compile the B2G? Or can I also do it no a 32bit architecture?

Comment 33

4 years ago
The problem is that in gecko code now Mozilla allows to make a 5Mpx photo and this breaks Peak's camera. Soon we will release a patch so you can use your camera, we are working on it.

Comment 34

4 years ago
Could you please let us know when the patch is going to be available? Also, do you know if I can compile the B2G using a 32bit machine? Even if the camera bug will be fixed, I would still like to compile it. 

Thank you,

Comment 35

4 years ago
No, like i said we are working on it. I cant give you a release date. About 32 bits, sorry... i cant help you.

Comment 36

4 years ago
Sorry, I was not asking for a release date. After you release it, if you can just drop a line here would be great. 

Thank you again,

Comment 37

4 years ago
Sure. You can follow our forums too.

Comment 38

4 years ago
The patch that you will release it will be on 1.1, 1.2 or 1.3?
(Reporter)

Comment 39

4 years ago
In latest v1.1.0hd, the camera application seems to work again : great!

So I took a photo to see its resolution : 1536*2048, which means ~3M Pixels
It's much better than 1.2M :-) ... but still far from expected 8M :-(

Any reason why we still have this limitation on Firefox OS, that does not seem to exist on Android?

Comment 40

4 years ago
I can confirm that the phone can now take pictures at 3MP. Do you have any idea, if it can take pictures at 5MP? Anyway, thank you very much for your prompt reaction and for solving the issue so quickly.

Comment 41

4 years ago
As we said in our comments, this was a gecko problem that has been fixed in this commit: http://git.mozilla.org/?p=releases/gecko.git;a=commit;h=6529acef3ef8c7e966cdefb86b91310941576c01

Now the camera can take photos at 5Mpx by default and 8Mpx with some gaia tweaks, but it lets to another problems:
1) With some 8Mpx images the rendering in the gallery last like 3 minutes, with more photos last more.
2) The preview in the camera is not correct, seems like it is zoomed.

If we get this fixed (at least the problem 2) we will release a 1.1 stable image with this changes.

Comment 42

4 years ago
The stable release has been released with this fixes. Now 8mpx camera is working with gallery ok.

Comment 43

4 years ago
This is great news. Thank you very much. The latest 1.1 works with the camera at 8mp or only the latest stable 1.1?

Comment 44

4 years ago
Only stable 1.1

Comment 45

4 years ago
Thank you guys for fixing this!
(Reporter)

Comment 46

4 years ago
Yeahh! Finally 8MP photos!
Reading QR codes works much better.
Thanks geeksphone for your work on that.

Photos are frequently blur anyway, I suppose the autofocus is not very accurate but that's another issue.

It seems that I don't have the right to change the status of this issue to "fixed" : if someone has, please do
Closing as per comment 46
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.