mach error: unable to file build information file (mozinfo.json) at this location: objdir/dist/bin/firefox/mozinfo.json

RESOLVED DUPLICATE of bug 901136

Status

Firefox Build System
Mach Core
RESOLVED DUPLICATE of bug 901136
5 years ago
3 months ago

People

(Reporter: msucan, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
I just pulled from fx-team and now mach won't run mochitest-chrome/mochitest-browser at all. Yesterday it all worked well (thanks to the fix for bug 900444).


$ mach mochitest-chrome toolkit/devtools/webconsole/test

Usage: Usage instructions for runtests.py.
    All arguments are optional.
    If --chrome is specified, chrome tests will be run instead of web content tests.
    If --browser-chrome is specified, browser-chrome tests will be run instead of web content tests.
    See <http://mochikit.com/doc/html/MochiKit/Logging.html> for details on the logging levels.
    

mach: error: Unable to file build information file (mozinfo.json) at this location: /home/mihai/Public/builds/firefox/fx-team/browser-opt/dist/bin/firefox/mozinfo.json


I tried a clobber, same result. What shall I do?
The patch in bug 901136 should fix this.  The patch is already landed on fx-team and will be merged to mozilla-central within a day or two.  Or as a temporary workaround you can run this command in your objdir:

TEST_PATH=toolkit/devtools/webconsole/test make mochitest-chrome
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 901136

Updated

5 years ago
Blocks: 912114

Updated

3 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.