Closed Bug 901234 Opened 6 years ago Closed 6 years ago

Stop using uriTypes (Places Session ids) in SeaMonkey code

Categories

(SeaMonkey :: Bookmarks & History, defect)

defect
Not set

Tracking

(seamonkey2.26 fixed)

RESOLVED FIXED
seamonkey2.27
Tracking Status
seamonkey2.26 --- fixed

People

(Reporter: mcsmurf, Assigned: mcsmurf)

References

Details

Attachments

(1 file)

uriTypes (Places Session ids) have been deprecated by Bug 561450 and should not be used anymore. See for example http://mxr.mozilla.org/comm-central/search?string=uritypes for places where it is still used (there are also other places where sessions ids are still used).
What I have locally so far.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
See Bug 561450 for the Firefox version of the bug.
Component: General → Bookmarks & History
Comment on attachment 785395 [details] [diff] [review]
First attempt at patch

We need this RSN because of bug 969408.
Attachment #785395 - Flags: review+
Doh, somehow this patch got lost. Pushed: https://hg.mozilla.org/comm-central/rev/f081b6e4c8de
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.27
Duplicate of this bug: 979265
Duplicate of this bug: 979402
Duplicate of this bug: 979369
Blocks: 1018792
landing to comm-release for SeaMonkey 2.26.1

$ hg tip
changeset:   20174:9f7c2c32fad1
branch:      SEA_2_26_1_RELBRANCH
tag:         tip
user:        Frank Wein <mcsmurf@mcsmurf.de>
date:        Wed Mar 05 13:53:12 2014 +0100
summary:     Bug 901234 - Stop using uriTypes (Places Session ids) in SeaMonkey code, r=Neil, a=me
You need to log in before you can comment on or make changes to this bug.