Xcode5-DPx/Xcode5 not recognized by bootstrap.

RESOLVED FIXED in Firefox 27

Status

defect
--
minor
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: jsbruner, Assigned: gps)

Tracking

unspecified
mozilla27
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(firefox27 fixed, firefox-esr24 fixed, b2g-v1.2 fixed)

Details

(Whiteboard: [see_comment_4_for_fix])

Attachments

(1 attachment)

The bootstrap script does not check for Xcode-DPx (where x is some DP version). Because of this the bootstrap script will stop and force you to either change Xcode-DPx's name to Xcode or download the normal Xcode. This is especially a problem on the developer preview of Mavericks, since the old Xcode is not even allowed to be installed.

We should allow bootstrap to use Xcode-DPx as long as it is in the Applications directory.
Correction, this is about "Xcode5-DPx" and "Xcode5". I'm guessing the Xcode5 is the real issue.
Summary: Xcode-DPx not recognized by bootstrap. → Xcode5-DPx/Xcode5 not recognized by bootstrap.
Assignee

Comment 2

6 years ago
Can you please provide the necessary context to fix this? e.g. what are the actual directory names and/or version numbers? Can you provide the output from the bootstrapper demonstrating the error?
Flags: needinfo?(josiah)
(In reply to Gregory Szorc [:gps] from comment #2)
> Can you please provide the necessary context to fix this? e.g. what are the
> actual directory names and/or version numbers? Can you provide the output
> from the bootstrapper demonstrating the error?

In /Applications/ there is a Xcode5-DP4.app. Command line tools have been installed.

I run the boostrap command in ~/Development/Mozilla/. I can't remember the exact output and can't test it currently since I'm on a different machine right now, but it was something along the lines of:

"Xcode not installed

 Xcode is required to build Firefox, please install Xcode and try again"

or something like that. It opens up Xcode in the Mac App Store, but it won't install on Mavericks.

This is on OS X 10.9 DP 4. Though it happens on every DP version.
Flags: needinfo?(josiah)
You have to run xcode-select -p /Applications/Xcode5-DPX.app first. Then the right paths and aliases have been setup and the script finds Xcode just fine.
(In reply to Stefan Arentz [:st3fan] from comment #4)
> You have to run xcode-select -p /Applications/Xcode5-DPX.app first. Then the
> right paths and aliases have been setup and the script finds Xcode just fine.

Ah, cool. Forgot about that. Thanks. Marking as RESOLVED.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [see_comment_4_for_fix]
Assignee

Comment 6

6 years ago
I installed Mavericks and encountered this issue. Might as well fix it.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Assignee

Comment 7

6 years ago
I installed a developer preview of Mavericks and was able to reproduce
this bug. This patch appears to fix it for me.
Attachment #805611 - Flags: review?(mshal)
Assignee

Updated

6 years ago
Assignee: nobody → gps
Note that, in my (rather limited) experience, xcode-select --print-path *always* returns incorrect information on OS X 10.9 until xcode-select --switch has been run at least once.

If I remember right, this incorrect information is /Library/Developer/CommandLineTools.
Assignee

Comment 9

6 years ago
(In reply to Steven Michaud from comment #8)
> Note that, in my (rather limited) experience, xcode-select --print-path
> *always* returns incorrect information on OS X 10.9 until xcode-select
> --switch has been run at least once.
> 
> If I remember right, this incorrect information is
> /Library/Developer/CommandLineTools.

That's why I check for ".app/" in the returned path :)
Comment on attachment 805611 [details] [diff] [review]
More intelligently detect installed Xcode

Looks good!
Attachment #805611 - Flags: review?(mshal) → review+
https://hg.mozilla.org/mozilla-central/rev/f05d9623c6d3
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Just a quick not that OS X 10.9 GM was released together with Xcode 5.0.1 GM. The latter is now simply named 'Xcode.app' and the 'installer' encourages you to drag it to /Applications/ .. so there should be no special cases or checks needed.

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.