Harvard business school login form . Chrome works fine firefox wronly interprets my enter key

RESOLVED DUPLICATE of bug 286933

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 286933
5 years ago
5 years ago

People

(Reporter: nitin.arya, Unassigned)

Tracking

22 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 785498 [details]
bug.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Harvard business school login form . Chrome works fine Firefox wrongly interprets my enter key
http://cb.hbsp.harvard.edu/cb/login



Actual results:

when your username is saved and you press the enter to select your username from drop down  it just logs in without entering the passkey so you always have to use mouse to select your username from drop down list.


Expected results:

Like in chrome . just press enter when when your username is depicted and then user can press tab key to go to passkey field and then pressing enter should try to log in .

Comment 1

5 years ago
Could you try with a clean profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(nitin.arya)
(Reporter)

Comment 2

5 years ago
Yes tested with fresh profile . same behaviour of firefox.
Flags: needinfo?(nitin.arya)

Comment 3

5 years ago
Probably because they use some Javascript tricks with the form. And because it works in Chrome doesn't imply it's normal.

Comment 4

5 years ago
Any idea, Alice? (the login page can be tested without valid credentials)
(Reporter)

Comment 5

5 years ago
yap just enter any username press login and then again when u select that username from dop down list in login form and press enter it just presses submit button but in normal behaviour it should just enter the username with first button press .

Comment 6

5 years ago
Maybe duplicate of Bug 286933

The problem is onkeypress handler of username field.
Press ENTER on the dropdown list> keypress event fires > document.getElementById("loginForm").submit();

"http://cb.hbsp.harvard.edu/cb/login":
<input id="j_username" name="j_username" onkeypress="javascript: return enter(event)" type="text">


"/cb/scripts/he-home.js" :
function enter(event) { 
	var code = getKeyCode(event);
	if (code == 13 && document.getElementById("loginForm") != null) {
		showLoadingDialog();
		document.getElementById("loginForm").submit();
	}
	return true;
}

Comment 7

5 years ago
Probably a dupe, yes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286933
You need to log in before you can comment on or make changes to this bug.