Last Comment Bug 901469 - Australis + Shiki Dust GTK/Murrine theme: bookmarking menu has white text, but light background (theme makes menus' bg black/dark).
: Australis + Shiki Dust GTK/Murrine theme: bookmarking menu has white text, bu...
Status: VERIFIED FIXED
[Australis:P4][Australis:M9]
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86_64 Linux
-- normal (vote)
: Firefox 28
Assigned To: Mike de Boer [:mikedeboer]
:
: Dão Gottwald [:dao]
Mentors:
Depends on:
Blocks: australis-cust 970205
  Show dependency treegraph
 
Reported: 2013-08-05 03:28 PDT by [:Aleksej]
Modified: 2014-02-09 23:57 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
shiki-dust-australis-20130804-default.png (101.01 KB, image/png)
2013-08-05 03:28 PDT, [:Aleksej]
no flags Details
LWT "Black Elegance" doesn't help (58.29 KB, image/png)
2013-08-05 03:29 PDT, [:Aleksej]
no flags Details

Description User image [:Aleksej] 2013-08-05 03:28:50 PDT
Created attachment 785694 [details]
shiki-dust-australis-20130804-default.png

2013-08-04-04-02-17-ux-firefox-25.0a1.en-US.linux-x86_64

Debian GNU/Linux jessie with Xfce

Shiki-Dust theme (package cites http://code.google.com/p/gnome-colors/ as its source), which 
* makes the menu bars black with white text,
* the rest is supposed to be greyish with black text
(screenshot of a Shiki theme from its site: http://img113.imageshack.us/img113/706/867171.png ).

The drop-down menu of the right bookmarks button has white text on greyish background.

Installing dark LWT ("Black Elegance", "Black as Shiki") doesn't help.
Comment 1 User image [:Aleksej] 2013-08-05 03:29:50 PDT
Created attachment 785695 [details]
LWT "Black Elegance" doesn't help
Comment 2 User image Marco Bonardo [::mak] 2013-08-05 03:34:25 PDT
we must re-evaluate the styling in that panel, since it's also bad on Mac. Btw off-hand looks like a bug in the theme css, but it's early to fix it if the panel styling is not final.
Comment 3 User image :Gijs 2013-08-05 03:38:02 PDT
(In reply to Marco Bonardo [:mak] from comment #2)
> we must re-evaluate the styling in that panel, since it's also bad on Mac.
> Btw off-hand looks like a bug in the theme css, but it's early to fix it if
> the panel styling is not final.

I actually think comment #0 is talking about a Linux theme, which won't have CSS. We're probably specifying to use the system color for the view somewhere, but don't use the system background color...
Comment 4 User image Dão Gottwald [:dao] 2013-08-05 03:45:21 PDT
Comment on attachment 785695 [details]
LWT "Black Elegance" doesn't help

Lightweight themes don't affect popups.
Comment 5 User image :Gijs 2013-09-30 08:30:12 PDT
So yeah. We're using color: menutext (or color: graytext), but using the background color of the panel, ie -moz-dialog. By happy coincidence, that works alright for common Windows/OS X combinations, but for more 'interesting' themes, it can be wrong. Like here. We should probably either style the menuitems inside the panel-esque menu (because it looks like it's still inside a menu popup, but with some panel arrows and such?) to have the right color, or we could style the panel to have a menu background color. The latter would also solve bug 900162. However, in that bug the word is that the arrow's background color is fixed.
Comment 6 User image :Gijs 2013-10-28 03:31:20 PDT
This was fixed by bug 900162.
Comment 7 User image [:Aleksej] 2013-11-21 05:23:34 PST
I am not sure which color menus are supposed to be (switching between themes in Xfce while programs are running mixes some themes up, Xfce, GNOME and Mozilla programs behave differently), but this is verified fixed with 2013-11-17-03-02-03-mozilla-central-firefox-28.0a1.en-US.linux-x86_64: attachment 8335990 [details] (showing bug 941576 though: the submenu arrows are almost invisible).
Comment 8 User image [:Aleksej] 2013-11-21 05:25:56 PST
(In reply to Aleksej [:Aleksej] from comment #7)

And note that the submenus which those arrows open are white on black.

Note You need to log in before you can comment on or make changes to this bug.