DownloadLegacySaver should move the ".part" file to the target

RESOLVED FIXED in Firefox 25

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Paolo, Assigned: Paolo)

Tracking

Trunk
mozilla26
Points:
---

Firefox Tracking Flags

(firefox25 fixed, firefox26 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
nsExternalHelperAppService expects DownloadLegacySaver to move the ".part" file
to the target, in case the download completes successfully.
(Assignee)

Comment 1

5 years ago
Created attachment 786277 [details] [diff] [review]
The patch
Attachment #786277 - Flags: review?(enndeakin)
Attachment #786277 - Flags: review?(enndeakin) → review+

Comment 3

5 years ago
https://hg.mozilla.org/mozilla-central/rev/a0b47189f0a6
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
(Assignee)

Comment 4

5 years ago
Comment on attachment 786277 [details] [diff] [review]
The patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined:
 - When flipping the "browser.download.useJSTransfer" preference to test the
   new Downloads API, testers and add-on authors will see empty downloads
   in the most common use case.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky):
 - Low, feature is not enabled by default.
String or IDL/UUID changes made by this patch: None
Attachment #786277 - Flags: approval-mozilla-aurora?
Attachment #786277 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/d3e60eab3da5
status-firefox25: --- → fixed
status-firefox26: --- → fixed
Assuming no verification needed here. Please add the verifyme keyword and remove the [qa-] whiteboard tag to request verification.
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.