Invalidate ProfileInformationCache after fixing add-on uninstallation

RESOLVED FIXED in Firefox 24

Status

defect
RESOLVED FIXED
6 years ago
8 months ago

People

(Reporter: rnewman, Assigned: mcomella)

Tracking

unspecified
Firefox 26
All
Android
Dependency tree / graph

Firefox Tracking Flags

(firefox24+ fixed, firefox25 fixed, firefox26 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

6 years ago
Just about to uplift Bug 900694 to Beta (pre B1). We should fix existing badness, too.
Assignee: nobody → michael.l.comella
Reporter

Comment 1

6 years ago
Flaggin' for trackin'.

Release folks: this'll be the follow-on from Bug 900694 -- blowing away cached data to make sure we have an accurate snapshot of the user's add-ons, and are thus recording FHR events correctly.
Status: NEW → ASSIGNED
Reporter

Comment 3

6 years ago
r+
Flags: needinfo?(rnewman)
https://hg.mozilla.org/mozilla-central/rev/3c188512a17c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Comment on attachment 786979 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
    Initial landing of FHR and the fix deployed in Bug 900694 (already uplifted to 24).

User impact if declined: 
    Misrecorded addon data will propagate until cache is invalidated (which occurs on version bump - this patch - or corruption)

Testing completed (on m-c, etc.): 
    Tested locally, on m-c one week, unit tests via github (https://github.com/mozilla-services/android-sync/pull/345)

Risk to taking this patch (and alternatives if risky):
    Low risk - a version bump, whose behavior is tested by the unit tests linked above

String or IDL/UUID changes made by this patch:
    None
Attachment #786979 - Flags: approval-mozilla-beta?
Attachment #786979 - Flags: approval-mozilla-aurora?
Attachment #786979 - Flags: approval-mozilla-beta?
Attachment #786979 - Flags: approval-mozilla-beta+
Attachment #786979 - Flags: approval-mozilla-aurora?
Attachment #786979 - Flags: approval-mozilla-aurora+
Keywords: verifyme
Covered by unit tests
Keywords: verifyme

Updated

8 months ago
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.