Closed Bug 901876 Opened 9 years ago Closed 7 years ago

Assertion failure in nsSHEntry.cpp:625

Categories

(Core :: DOM: Navigation, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 855443

People

(Reporter: bobowen, Unassigned)

References

Details

The mochitests here https://bugzilla.mozilla.org/attachment.cgi?id=785922&action=edit caused this assert to fail: http://mxr.mozilla.org/mozilla-central/source/docshell/shistory/src/nsSHEntry.cpp#625 - NS_ERROR("Adding a child where we already have a child? This may misbehave");

I'm not sure, which new test has fired the assertion yet.

From log:
nsSHEntry::AddChild(nsISHEntry*, int) [docshell/shistory/src/nsSHEntry.cpp:626]
nsDocShell::AddChildSHEntry(nsISHEntry*, nsISHEntry*, int, unsigned int, bool) [docshell/base/nsDocShell.cpp:3757]
nsDocShell::DoAddChildSHEntry(nsISHEntry*, int, bool) [docshell/base/nsDocShell.cpp:3830]
nsDocShell::AddToSessionHistory(nsIURI*, nsIChannel*, nsISupports*, bool, nsISHEntry**) [docshell/base/nsDocShell.cpp:10778]
nsDocShell::OnNewURI(nsIURI*, nsIChannel*, nsISupports*, unsigned int, bool, bool, bool) [docshell/base/nsDocShell.cpp:10162]
nsDocShell::OnLoadingSite(nsIChannel*, bool, bool) [docshell/base/nsDocShell.cpp:10232]
nsDocShell::CreateContentViewer(char const*, nsIRequest*, nsIStreamListener**) [obj-firefox/dist/include/nsCOMPtr.h:538]
nsDSURIContentListener::DoContent(char const*, bool, nsIRequest*, nsIStreamListener**, bool*) [docshell/base/nsDSURIContentListener.cpp:125]
nsDocumentOpenInfo::TryContentListener(nsIURIContentListener*, nsIChannel*) [uriloader/base/nsURILoader.cpp:681]
nsDocumentOpenInfo::DispatchContent(nsIRequest*, nsISupports*) [uriloader/base/nsURILoader.cpp:382]
nsDocumentOpenInfo::OnStartRequest(nsIRequest*, nsISupports*) [uriloader/base/nsURILoader.cpp:260]
mozilla::net::nsHttpChannel::CallOnStartRequest() [netwerk/protocol/http/nsHttpChannel.cpp:1006]
mozilla::net::nsHttpChannel::ContinueProcessNormal(tag_nsresult) [netwerk/protocol/http/nsHttpChannel.cpp:1599]
mozilla::net::nsHttpChannel::ProcessNormal() [netwerk/protocol/http/nsHttpChannel.cpp:1533]
mozilla::net::nsHttpChannel::ProcessResponse() [netwerk/protocol/http/nsHttpChannel.cpp:1445]
mozilla::net::nsHttpChannel::OnStartRequest(nsIRequest*, nsISupports*) [netwerk/protocol/http/nsHttpChannel.cpp:5036]
nsInputStreamPump::OnStateStart() [netwerk/base/src/nsInputStreamPump.cpp:463]
nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) [netwerk/base/src/nsInputStreamPump.cpp:388]
nsInputStreamReadyEvent::Run() [xpcom/io/nsStreamUtils.cpp:82]
nsThread::ProcessNextEvent(bool, bool*) [xpcom/threads/nsThread.cpp:622]
NS_ProcessNextEvent(nsIThread*, bool) [obj-firefox/xpcom/build/nsThreadUtils.cpp:238]
mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) [ipc/glue/MessagePump.cpp:116]
MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:220]
MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:507]
nsBaseAppShell::Run() [widget/xpwidgets/nsBaseAppShell.cpp:165]
nsAppStartup::Run() [toolkit/components/startup/nsAppStartup.cpp:270]
XREMain::XRE_mainRun() [toolkit/xre/nsAppRunner.cpp:3859]
XREMain::XRE_main(int, char**, nsXREAppData const*) [toolkit/xre/nsAppRunner.cpp:3926]
XRE_main [toolkit/xre/nsAppRunner.cpp:4129]
do_main [browser/app/nsBrowserApp.cpp:275]
main [browser/app/nsBrowserApp.cpp:637]
++DOMWINDOW == 101 (0x9071118) [serial = 3252] [outer = 0xcde1e40]
Depends on: 855443
Attachment with the tests from the description, now superseded by:
https://bugzilla.mozilla.org/attachment.cgi?id=786305&action=edit
Bob, I had a similar issue as describe din bug 855443.  Do you know which test is causing this assertion failure?  Can you describe what the test does?  Thanks!
(In reply to Tanvi Vyas [:tanvi] from comment #2)
> Bob, I had a similar issue as describe din bug 855443.  Do you know which
> test is causing this assertion failure?  Can you describe what the test
> does?  Thanks!

Hi Tanvi ... we've been decorating the back bedroom (where the computers live) yesterday and putting up new office furniture today, so I've only had a bit of time to keep on top of bug 886262.
I'll try and isolate the test as soon as I can.
I also think that some of the existing sandbox tests might be having a similar problem.

Cheers,
Bob
Looks like smaug's fix for Bug 855443, fixed this.
So, I'll mark as a duplicate.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 855443
You need to log in before you can comment on or make changes to this bug.