Closed Bug 902059 Opened 6 years ago Closed 6 years ago

Enable mixed content blocking on Aurora

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 26
Tracking Status
firefox24 --- unaffected
firefox25 + verified
firefox26 --- verified

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

Attachments

(1 file)

All the follow-ups to bug 860581 have landed, so we should enable it on Aurora (right now it's still hidden behind an #ifdef NIGHTLY_BUILD).

Desktop just shipped mixed content blocking in release, so I don't think there's too much to worry about, but we can track any compatibility issues that arise as they come up.
Attached patch patchSplinter Review
Attachment #786596 - Flags: review?(mark.finkle)
Comment on attachment 786596 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): needed to enable mixed content blocking on aurora (bug 860581)
User impact if declined: mixed content blocking will be disabled
Testing completed (on m-c, etc.): been enabled on m-c for over one release cycle
Risk to taking this patch (and alternatives if risky): no risk other than potential follow-up work to this feature
String or IDL/UUID changes made by this patch: n/a
Attachment #786596 - Flags: approval-mozilla-aurora?
Attachment #786596 - Flags: review?(mark.finkle) → review+
Target Milestone: --- → Firefox 25
Attachment #786596 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/e966eb34cc03
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 25 → Firefox 26
Status: RESOLVED → VERIFIED
SoftVision, you can use https://people.mozilla.com/~bsterne/tests/62178/test.html as a test-page
Flags: in-moztrap?(fennec)
tracking-fennec: ? → ---
Test cases added in moztrap:
https://moztrap.mozilla.org/manage/cases/?filter-suite=441
Flags: in-moztrap?(fennec) → in-moztrap+
You need to log in before you can comment on or make changes to this bug.