Open Bug 902060 Opened 6 years ago Updated 6 years ago

GeckoProfile shouldn't be cached on the Activity

Categories

(Firefox for Android :: General, defect)

x86
Linux
defect
Not set

Tracking

()

People

(Reporter: wesj, Unassigned)

Details

We currently store a cached GeckoProfile for the current profile on GeckoApp. GeckoApp's lifecycle and Gecko's lifecycle aren't the same though, meaning this profile can be destroyed while Gecko lives on.

We should cache GeckoProfile on the Application instead.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 937945
Are you sure this is a dupe? I thought this bug was about the fact that we hold onto the profile in GeckoApp and then reference it elsewhere (http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/GeckoProfile.java#72). Bug 937945 won't fix this.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Hmm... you're right. I know a filed a bug for 937945, and thought from the title this was it :)
You need to log in before you can comment on or make changes to this bug.