language-specific minimum font size is propagated to pages of different language in same window

RESOLVED DUPLICATE of bug 687297

Status

()

RESOLVED DUPLICATE of bug 687297
5 years ago
5 years ago

People

(Reporter: mariang_iasi, Unassigned)

Tracking

26 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 4 obsolete attachments)

(Reporter)

Description

5 years ago
Created attachment 786422 [details]
badimage1.png

User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130806030203

Steps to reproduce:

I visited forum.softpedia.com where I am always logged in.
I leave the forum an went to https://bugzilla.mozilla.org, after that any page i visit is larger.


Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130806030203 CSet: a0dd80f800e2


Actual results:

The page appears slightly bigger.


Expected results:

Pages should not change sizes.
(Reporter)

Updated

5 years ago
Keywords: 64bit, fonts, site-compat
Hardware: x86 → x86_64
(Reporter)

Comment 1

5 years ago
Created attachment 786458 [details]
difference between same page, 1st part is after visiting forum
(Reporter)

Comment 2

5 years ago
Created attachment 786548 [details]
zip archive contains a profile with specific pref.js file

Steps to reproduce:
Load aw98t15c profile
Navigate to 1st and 2nd bookmarks w/o closing tab.
Then open 2nd bookmark in different tab.
You should see the difference.

Comment 3

5 years ago
Are you able to reproduce the issue with a clean profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Component: General → Layout
Flags: needinfo?(mariang_iasi)
Keywords: 64bit, fonts, site-compat
(Reporter)

Comment 4

5 years ago
I've created a new profile using firefox -p (manager) and it's provided in the attachment 786548 [details].
It has my custom font settings and 2 bookmarks for test purpose.

I've written a simple HTML page, and keeping provided profile (aw98t15c) just by adding 'charset=iso-8859-2' to 'meta http-equiv' I was able to make the second loaded page appear bigger.
(Reporter)

Comment 5

5 years ago
Created attachment 787138 [details]
html file, add/remove charset=iso-8859-2
Flags: needinfo?(mariang_iasi)

Updated

5 years ago
Attachment #787138 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 6

5 years ago
Basically it does not change the "minimum font size" accordingly to the new page's charset specification when it's loaded.
(Reporter)

Comment 7

5 years ago
Created attachment 788091 [details]
2 HTML webpages, note about font size,

2 pages 
with charset=iso-8859-1, and 
with charset=iso-8859-2
(Reporter)

Comment 8

5 years ago
Created attachment 788500 [details]
page_1_good.PNG
Attachment #786422 - Attachment is obsolete: true
Attachment #786458 - Attachment is obsolete: true
Attachment #786548 - Attachment is obsolete: true
Attachment #787138 - Attachment is obsolete: true
(Reporter)

Comment 9

5 years ago
Created attachment 788501 [details]
page_2_good.PNG
(Reporter)

Comment 10

5 years ago
Created attachment 788502 [details]
page_1_bad.PNG
(Reporter)

Comment 11

5 years ago
Created attachment 788503 [details]
user_defined.PNG

Comment 12

5 years ago
Could you post clear STR to repro the bug, please (which website, settings to modify etc).
Flags: needinfo?(mariang_iasi)
(Reporter)

Comment 13

5 years ago
Modify "minimun font size", for "Central European" (iso-8859-2) font make it a big value, so you can see.
Visit a page that use iso-8859-2 charset, then leave to a page that has iso-8859-1 charset (Western)
The page will use your western fonts, but it will keeps the font size for the iso-8859-2.
Flags: needinfo?(mariang_iasi)
This is certainly believable.  The pres context has code to get the right language-specific min font size, and then use the max of that and its overall min-font-size.  But there's also code in the document viewer and higher than tries to preserve min font size across page navigation, and that code preserves the max()-ed font size.  (I have no idea why it tries to preserve min font size across page navigation since I'm not aware of any page-specific way to set it.)

One fix might be to fix nsDocumentViewer::GetMinFontSize to do something that gets the cross-language min font size.  That said, I'm not sure *why* we have that cross-language min font size, or what it's for.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 8 → All
Hardware: x86_64 → All
Summary: Different size of text and images after I leave certain page. → language-specific minimum font size is propagated to pages of different language in same window
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 687297
You need to log in before you can comment on or make changes to this bug.