All users were logged out of Bugzilla on October 13th, 2018

Google easter egg Zerg Rush freezes Firefox with add-on Adblock Plus installed

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: hong620, Unassigned)

Tracking

(Blocks: 1 bug)

23 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130730113002

Steps to reproduce:

when browsing Google's 'Zerg Rush' Easter egg.


Actual results:

Freeze cause of overload Javascript

Updated

5 years ago

Comment 1

5 years ago
I think it's due to add-on Adblock Plus.
If I disable ABP, it's fine.

Could you confirm you have ABP and if it's disabled, it works fine (try in safe mode https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode).
Flags: needinfo?(hong620)
Summary: zerg rush JS Freezeing → Google easter egg Zerg Rush freezes Firefox

Updated

5 years ago
Blocks: 467520
(Reporter)

Comment 2

5 years ago
(In reply to Loic from comment #1)
> I think it's due to add-on Adblock Plus.
> If I disable ABP, it's fine.
> 
> Could you confirm you have ABP and if it's disabled, it works fine (try in
> safe mode
> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-
> mode).

Thx, it's work fine :D
Flags: needinfo?(hong620)

Updated

5 years ago
Summary: Google easter egg Zerg Rush freezes Firefox → Google easter egg Zerg Rush freezes Firefox with add-on Adblock Plus installed

Comment 3

5 years ago
Confirmed on old version like Firefox 8.
Component: Untriaged → Extension Compatibility

Comment 4

5 years ago
I tried to reproduce in a nightly (25.0a1 2013-08-02 - didn't update after vacation yet, sorry) but wasn't able to. That easter egg gets slower very soon if I let it run, this seems unrelated to Adblock Plus however - it happens exactly the same without Adblock Plus. There are no content policy calls while that easter egg is running so I cannot immediately see why Adblock Plus would slow anything down.

It would be great if somebody could answer the following questions:

* Does the hang happen immediately or after leaving the page open for a while? If it's the former, does the page manage to display something (what exactly)?
* What if you click the ABP icon and check "Disable everywhere", does it still hang?
* Which Adblock Plus version are we talking about?
* How is Adblock Plus configured (click ABP icon and go to Filter Preferences)? I assume that EasyList is selected under "Filter subscriptions" and "Allow some non-intrusive advertising" is checked? What is listed as "Last download" date?

Comment 5

5 years ago
Yes, you're right. The faulty element is a filter of EasyList:
##.mw > #rcnt > #center_col > #taw + div[style]

With this filter disabled, the easter egg works fine and doesn't hang Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.