Closed Bug 902453 Opened 6 years ago Closed 6 years ago

Simple gUM Test Page demo not working on Firefox for Android (Beta) 24.0 - ReferenceError: browser is not defined -- no media selection prompt

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 24
Tracking Status
firefox23 --- unaffected
firefox24 + verified
firefox25 --- unaffected
firefox26 --- unaffected

People

(Reporter: aaronmt, Assigned: mfinkle)

References

(Blocks 1 open bug, )

Details

(Keywords: reproducible, Whiteboard: [getUserMedia][android-gum+])

Attachments

(1 file)

Visit http://mozilla.github.io/webrtc-landing/gum_test.html, tap 'Video' or 'Audio' or 'Audio & Video'

08-07 10:36:52.625 E/GeckoConsole( 4850): [JavaScript Error: "ReferenceError: browser is not defined" {file: "chrome://browser/content/WebrtcUI.js" line: 84}]

One would have expected to see the hardware selection drop-down, but instead there is a browser is not defined error.

If this is not an error as part of WebRTC core, please move back to Firefox for Android :: General.
tracking-fennec: --- → ?
Summary: Simple gUM Test Page demo not working on Firefox for Android (Beta) 24.0 - ReferenceError: browser is not defined → Simple gUM Test Page demo not working on Firefox for Android (Beta) 24.0 - ReferenceError: browser is not defined -- no media selection prompt
Also seeing this on http://talky.io, there is no media prompt drop-down.

08-07 10:43:05.803 E/GeckoConsole( 6429): [JavaScript Error: "ReferenceError: browser is not defined" {file: "chrome://browser/content/WebrtcUI.js" line: 84}]
UI issue, not core
Component: WebRTC → General
Product: Core → Firefox for Android
Target Milestone: --- → Firefox 24
Hardware: x86 → ARM
Bad uplift of bug 885768. That patch should've given a merge conflict without the first patch going in as well :-/
Whiteboard: [getUserMedia][android-gum?] → [getUserMedia][android-gum+]
Depends on: 885768
This bug exists because bug 885768 was uplifted to Fx24, but bug 894882 was not.
Depends on: 894882
No longer depends on: 885768
This is the same patch from bug 894882, just updated to apply in mozilla-beta.
Assignee: nobody → mark.finkle
Attachment #786960 - Flags: review?(gpascutto)
Attachment #786960 - Flags: review?(gpascutto) → review+
Comment on attachment 786960 [details] [diff] [review]
unbitrotted patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bad uplift
User impact if declined: no webrtc
Testing completed (on m-c, etc.): m-c and m-a both have the right patches
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #786960 - Flags: approval-mozilla-beta?
Comment on attachment 786960 [details] [diff] [review]
unbitrotted patch

Please land asap.

Also adding verifyme to test.
Attachment #786960 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Keywords: verifyme
https://hg.mozilla.org/releases/mozilla-beta/rev/e7215f239d6a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
tracking-fennec: ? → ---
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.