TD BGCOLOR cells would not be visible unless I added a &nobr;

RESOLVED DUPLICATE of bug 8113

Status

enhancement
RESOLVED DUPLICATE of bug 8113
18 years ago
14 years ago

People

(Reporter: abrody, Assigned: asa)

Tracking

Trunk
mozilla0.9.2
PowerPC
macOS

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

413 bytes, text/html
Details
When I added &nobr; to cells I get the colors I used in the <TD BGCOLOR=""> tag,
and it came out OK in http://www.index-site.com/browser.html
All other carbon/cocoa browsers were able to distinguish BGCOLOR tags in tables
without the aid of a no breaking space character.  Please make it possible in
Mozilla.
Added Mozilla version to the report.
Target Milestone: --- → mozilla0.9.2
This is a quirk.  It's only present in quirks mode (pages with no doctype or
known quirks doctypes).  Add a doctype declaration (4.01 Transitional with URI,
for that page) to your page and you will see the per-spec behavior.  In quirks
mode you see the "NS 4.x" behavior.

Marking duplicate of bug 4510, which proposes to get rid of all table background
quirks.

*** This bug has been marked as a duplicate of 4510 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
*** Bug 90806 has been marked as a duplicate of this bug. ***
Posted file testcase
Boris, you are wrong. If a page author want's to show empty cells in a table he
has to say so. By setting empty-cells:show these cells are shown. In quirks mode
we initialize empty-cells: hide and in standard mode to empty-cells:show. The
CSS2 spec makes no hint to which value this should be initialized. By switching
the doctype the author relies on the UA to get the default behavior. NN 4x use
empty-cells:hide and you can't switch it. 
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 8113 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
*** Bug 90908 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.