Last Comment Bug 902515 - Internet Explorer 11 receives multipart/x-mixed-replace content from buglist.cgi
: Internet Explorer 11 receives multipart/x-mixed-replace content from buglist.cgi
Status: RESOLVED FIXED
:
Product: Bugzilla
Classification: Server Software
Component: Query/Bug List (show other bugs)
: 4.2.6
: All All
: -- normal (vote)
: Bugzilla 4.0
Assigned To: Frédéric Buclin
: default-qa
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 10:01 PDT by Timo Kinnunen
Modified: 2016-04-26 05:33 PDT (History)
7 users (show)
justdave: approval+
justdave: approval4.4+
mail: approval4.2+
mail: approval4.0+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Request-response pair exported from F12 tool in IE11 showing headers used (6.37 KB, text/plain)
2013-08-07 10:01 PDT, Timo Kinnunen
no flags Details
Search results received by IE11 (810.46 KB, application/octet-stream)
2013-08-07 10:03 PDT, Timo Kinnunen
no flags Details
patch, v1 (696 bytes, patch)
2013-08-07 12:03 PDT, Frédéric Buclin
dkl: review+
Details | Diff | Splinter Review
20131101_153817.jpg (deleted)
2013-12-04 23:22 PST, laniey
no flags Details

Description Timo Kinnunen 2013-08-07 10:01:33 PDT
Created attachment 786987 [details]
Request-response pair exported from F12 tool in IE11 showing headers used

User Agent: HTML5

Steps to reproduce:

I clicked the Search tab on this Bugzilla, selected "all" and entered "internet explorer" to the search field, then pressed enter to search this Bugzilla for all bugs related to Internet Explorer 11.


Actual results:

Bugzilla sent the results back to IE11, which offered to save it to a file named buglist. Examining the HTTP traffic shows that Bugzilla was using multipart/x-mixed-replace as a Content-Type, which isn't part of HTML5 and doesn't appear to be standardized anywhere at all.


Expected results:

Bugzilla should have sent the results back using regular HTML5. If asynchronously loaded results are needed for better user experience Bugzilla should have used Server-Sent Events with AJAX fallback for browsers where S-SE are not available.

Using F12 Developer Tools to use a custom user-agent like "HTML5" instead of the default "Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" and everything else being the same leads to the search working correctly.
Comment 1 Timo Kinnunen 2013-08-07 10:03:42 PDT
Created attachment 786988 [details]
Search results received by IE11
Comment 2 Frédéric Buclin 2013-08-07 11:05:06 PDT
Bugzilla uses HTML 4.01 Transitional, not HTML5, and so doesn't use Server-Sent Events which is part of HTML5. And per http://en.wikipedia.org/wiki/Server-sent_events, Internet Explorer doesn't support this technology anyway.

IE11 gets multipart/x-mixed-replace because its UserAgent string doesn't follow older versions of IE, i.e. both "MSIE" and "compatible" are gone. This breaks our detection of the browser.
Comment 3 Frédéric Buclin 2013-08-07 11:18:09 PDT
Also note that if IE11 UserAgent string contains "like Gecko", then IE11 should work like Gecko, i.e. support the server-push technology. As suggested on http://msdn.microsoft.com/en-us/library/ie/bg182625%28v=vs.85%29.aspx, we should look for "Trident" to detect IE.
Comment 4 Frédéric Buclin 2013-08-07 12:03:18 PDT
Created attachment 787053 [details] [diff] [review]
patch, v1

Trident is present in the UserAgent string since IE8.
Comment 5 David Lawrence [:dkl] 2013-08-08 13:05:44 PDT
Comment on attachment 787053 [details] [diff] [review]
patch, v1

Review of attachment 787053 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Comment 6 Dave Miller [:justdave] (justdave@bugzilla.org) 2013-08-08 18:26:24 PDT
We were just discussing this on IRC, the reasoning for putting this on the 4.2 and 4.0 branches also is because these branches will still be supported when IE11 releases, and major browser compatibility issues are a big deal.
Comment 7 Frédéric Buclin 2013-08-09 02:33:51 PDT
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified buglist.cgi
Committed revision 8698.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.4/
modified buglist.cgi
Committed revision 8593.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.2/
modified buglist.cgi
Committed revision 8223.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified buglist.cgi
Committed revision 7755.
Comment 8 laniey 2013-12-04 23:22:43 PST
Created attachment 8342904 [details]
20131101_153817.jpg

Thank
Comment 9 Andre Klapper 2013-12-05 03:05:26 PST
Ianiey: Do NOT use bugzilla.mozilla.org for testing, as this is a production Bugzilla!
Use https://landfill.bugzilla.org/ for testing Bugzilla instead!
Comment 10 Frédéric Buclin 2013-12-05 04:09:37 PST
Comment on attachment 8342904 [details]
20131101_153817.jpg

Some bmo admin please delete this attachment.
Comment 11 Dave Miller [:justdave] (justdave@bugzilla.org) 2013-12-05 08:32:42 PST
The content of attachment 8342904 [details] has been deleted for the following reason:

mistaken upload
Comment 12 admin 2014-07-10 17:31:40 PDT
I am also seeing this issue still on v4.4
Comment 13 Byron Jones ‹:glob› 2014-07-13 22:12:38 PDT
(In reply to admin from comment #12)
> I am also seeing this issue still on v4.4

please file a new bug if you think this issue has not been fixed.  make sure you include both the bugzilla and IE versions.

Note You need to log in before you can comment on or make changes to this bug.