VariablesView does not distinguish between right and left clicks

RESOLVED FIXED in Firefox 27

Status

()

Firefox
Developer Tools: Object Inspector
P3
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Dan Morgan, Assigned: benvie)

Tracking

Trunk
Firefox 27
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.95 Safari/537.36

Steps to reproduce:

1. Running Dev Tools
2. Open Debugger
3. Put in a breakpoint, wait for breakpoint
4. Looking at an object in the watch screen, and see that I can click it.  I right click to bring up a context menu.


Actual results:

Instead of a context menu, the debugger treats the right click as a left click and expands 


Expected results:

I expected a context menu, hopefully with a way to copy the value.  Since this was a JSON based object, I was hoping I could copy the contents as JSON.  (I was able to solve the problem by adding a watch on JSON.stringify(json) and then highlighting the variable.) Chrome Dev Tools and Firebug both have this functionality built in.

Updated

5 years ago
Component: Untriaged → Developer Tools: Debugger
(Assignee)

Updated

4 years ago
Assignee: nobody → bbenvie
OS: Mac OS X → All
Priority: -- → P3
Hardware: x86 → All
Version: 22 Branch → Trunk
(Assignee)

Updated

4 years ago
Status: UNCONFIRMED → NEW
Component: Developer Tools: Debugger → Developer Tools: Object Inspector
Ever confirmed: true
(Assignee)

Updated

4 years ago
Summary: In Dev Tools > Debugger when I right click a JS variable it acted like a left click → VariablesView does not distinguish between right and left clicks
(Assignee)

Comment 1

4 years ago
Created attachment 816793 [details] [diff] [review]
bug-902539.patch

Adds checks to _onClick, _onEdit, and _onDelete to bail out if it's not the left mouse button.
(Assignee)

Comment 2

4 years ago
Created attachment 816806 [details] [diff] [review]
bug-902539.patch

Fix pressing delete key wouldn't cause a delete, add a test.

https://tbpl.mozilla.org/?tree=Try&rev=7907ffd5b1b0
Attachment #816793 - Attachment is obsolete: true
Attachment #816806 - Flags: review?(vporof)
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Attachment #816806 - Flags: review?(vporof) → review+
There's no r=? in this commit.
(Assignee)

Comment 5

4 years ago
Crap!
https://hg.mozilla.org/mozilla-central/rev/0cce3352d103
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27
You need to log in before you can comment on or make changes to this bug.