Closed Bug 902839 Opened 8 years ago Closed 8 years ago

[dev][stage] Signature summary does not load on report/list pages

Categories

(Socorro :: General, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mbrandt, Assigned: peterbe)

Details

(Whiteboard: [regression])

Attachments

(1 file)

Here's most likely the exception 
https://errormill.mozilla.org/webtools/socorro-dev/group/65718/ although that's from dev and not stage. 

I'm investigating.
PR https://github.com/mozilla/socorro/pull/1392
Assignee: nobody → peterbe
Status: NEW → ASSIGNED
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/d120ecf17f56924e1238c27e16c8f2e0fdc3b36e
fixes bug 902839 - signature summary untested on product_list, r=selenamarie
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Reopening:

A portion of the behavior still appears to be occurring, the #summary tab briefly displays it's data before it flashes away. Note the js errors are no longer present.

http://screencast.com/t/l5CJM2V2z

https://crash-stats-dev.allizom.org/report/list?product=Firefox&range_value=7&range_unit=days&date=2013-08-11&signature=SetWindowLongPtrWHook%28HWND__*%2C+int%2C+__int64%29&version=Firefox%3A26.0a1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I should note that comment 5 is for stage only - the signature summary section does not load on stage. See video in comment 4.
We probably have to backfill to get this to work. I'll backfill 7 days on stage and see if that fixes it.
(In reply to Selena Deckelmann :selenamarie :selena from comment #7)
> We probably have to backfill to get this to work. I'll backfill 7 days on
> stage and see if that fixes it.

Thanks Selena.

If this is due to a lack of data should the UI fail more gracefully?
(In reply to Matt Brandt [:mbrandt] from comment #8)
> (In reply to Selena Deckelmann :selenamarie :selena from comment #7)
> > We probably have to backfill to get this to work. I'll backfill 7 days on
> > stage and see if that fixes it.
> 
> Thanks Selena.
> 
> If this is due to a lack of data should the UI fail more gracefully?

Yeah, that's a good point. The queries that ran before could return no results, but it was pretty unlikely.

I'm not sure where to implement that -- maybe :peterbe or :brandonsavage can weigh in on what the middleware implementation should provide if no data is found for a date range.
Flags: needinfo?(peterbe)
If the UI doesn't do a good job of saying "Sorry. No data found" even though nothing is wrong then that has to become a new follow up bug to improve the UI. Really good point though Matt!
Flags: needinfo?(peterbe)
Backfill was completed, and as soon as a portion of the data was available, signature summaries re-appeared.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Sorry. Still SQL errors.
https://errormill.mozilla.org/webtools/socorro-dev/group/76125/
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This was due to a lack of migration on stage. I've got a ticket open to automate migrations in the future.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.