The opacity on the background image of everything.me force extra repaints when panning

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Homescreen
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: vingtetun, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

The css rule |#search-overlay { opacity: 0.4 }| in apps/homescreen/everything.me/modules/BackgroundImage/BackgroundImage.css force some extra repaints when panning and degrade the panning experience.

Dealing with opacity a different way should improve user experience.
The search-overlay opacity and logic have been changed.
Now, only the grid darkened layer is used.
Even without the change you mentionned it seems like it does not happen on the Leo device I have handy. That's fun - then let's forgot it for leo!
Apparently it happens only on mozilla-central. Can't reproduce on Unagi or Leo with a b2g18 build.
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.