SVG rendering error (protrusion) with hardware acceleration enabled

RESOLVED DUPLICATE of bug 854296

Status

()

RESOLVED DUPLICATE of bug 854296
5 years ago
5 years ago

People

(Reporter: bjornkl, Unassigned)

Tracking

({regression})

15 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 787461 [details]
scree_dump.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Tried to render two lines as polygons. They should not cross:

<!--?xml version="1.0" encoding="UTF-8"?-->
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.0//EN" "http://www.w3.org/TR/2001/REC-SVG-20010904/DTD/svg10.dtd">
<svg style="fill-opacity:1; stroke:black;" xmlns="http://www.w3.org/2000/svg"  xlink="http://www.w3.org/1999/xlink" height="30" width="30">
<g transform="translate(10,10)" >
<polygon style="fill:none; stroke-width:1;" points=" 0 5 0 -5"></polygon>
<polygon style="fill:none; stroke-width:1;" points=" 0 5 -5 5"></polygon>
</g>
</svg>



Actual results:

The two lines cross (intersect). See attached screen-dump.


Expected results:

The two lines should meet at [0,5]
Created attachment 787462 [details]
testcase as attachment

Updated

5 years ago
Attachment #787462 - Attachment mime type: text/plain → image/svg+xml
Seems to be connected with hardware acceleration. Turning it off stops the protrusion.

Updated

5 years ago
Summary: SVG rendering error in Firefox 22.0 on Windows 2007 → SVG rendering error (protrusion) with hardware acceleration enabled

Comment 3

5 years ago
Regression range:
good=2012-05-23
bad=2012-05-24
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=36e938e51481&tochange=f43e8d300f21

Suspected: 
Bas Schouten — Bug 715768: Enable Azure-Thebes wrapper by default for D2D. r=jrmuizel
Blocks: 715768
Status: UNCONFIRMED → NEW
Component: SVG → Graphics
Ever confirmed: true
Keywords: regression
Version: 22 Branch → 15 Branch

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 854296
You need to log in before you can comment on or make changes to this bug.