Closed Bug 902932 Opened 6 years ago Closed 6 years ago

Regression: Unable to tap an add-on to access associated options

Categories

(Firefox for Android :: Add-on Manager, defect)

26 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 26
Tracking Status
firefox23 --- unaffected
firefox24 --- unaffected
firefox25 --- unaffected
firefox26 --- verified
fennec 26+ ---

People

(Reporter: aaronmt, Assigned: ckitching)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

A regression in recent Add-Ons manager changes has resulted in basic Add-On Manager functionality at loss. Currently when one long-taps an add-on one is unable to access the context-menu associated with disabling and uninstalling an add-on.

--
Nightly (08/08)
HTC One (Android 4.2) | Samsung Galaxy S4 (Android 4.3)
Version: Firefox 24 → Firefox 26
Mixed this up, I meant the single-tap roll-out options list.
Summary: Regression: Unable to long-tap an add-on to access associated context-menu → Regression: Unable to tap an add-on to access associated options
When I long-tap an add-on

E/GeckoConsole(13789): [JavaScript Warning: "WARN addons.manager: Exception calling callback: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/aboutAddons.js :: getAddons/< :: line 261"  data: no]" {file: "chrome://browser/content/aboutAddons.js" line: 261}]
E/GeckoConsole(13789): [JavaScript Error: "TypeError: document.getElementById(...) is null" {file: "chrome://browser/content/aboutAddons.js" line: 64}]
When tapping on an add-on row:

E/GeckoConsole(19190): [JavaScript Error: "defaultButton is null" {file: "chrome://browser/content/aboutAddons.js" line: 352}]
tracking-fennec: ? → 26+
It appears the latest version of the part 3 patch from bug 892113 that I uploaded is not the latest one I created.
Due to this error, not all of the code that ought to have been deleted from aboutAddons.js was deleted, and the leftovers are now complaining about the nonexistence of that which has been deleted (The objective was to remove the old search engine customisation functionality from aboutAddons.js, as it is now obsolete.)

Here's a patch to finish the job. Sorry about that. Turns out that stupid things happen when I attempt to rush a patch into a release.
Assignee: nobody → ckitching
Status: NEW → ASSIGNED
Attachment #787812 - Flags: review?(liuche)
Comment on attachment 787812 [details] [diff] [review]
Remove the offending code.

Review of attachment 787812 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry about that - I thought I reviewed these changes already too, but it's also my fault for not noticing that the patch was missing parts.

This looks good, and building and testing this, none of the errors from before are present anymore.
Attachment #787812 - Flags: review?(liuche) → review+
landed on fx-team: https://hg.mozilla.org/integration/fx-team/rev/5446f1cddcaf
Target Milestone: --- → Firefox 26
https://hg.mozilla.org/mozilla-central/rev/5446f1cddcaf
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Blocks: 892113
You need to log in before you can comment on or make changes to this bug.