crash if I try to view source of IMAP acount mail message with attachment

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P2
critical
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Saulius Gurklys, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash, stackwanted})

Trunk
x86
All
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    
2001062815

If I try to view message source from IMAP account which has attachemnt
mozilla crashes with messagebox:
"The instruction at "0x608b61d" referenced memory at "0x00000000". The memory
could not be "read"..."

I have several IMAP acounts.

Reproducible: Sometimes
Steps to Reproduce:
1.Select message
2.View->Message Source or press Ctr+U
3.

Actual Results:  I got the message box with text:

"The instruction at "0x608b61d" referenced memory at "0x00000000". The memory
could not be "read"..."





Expected Results:  Show the message source

Updated

17 years ago
Keywords: crash
Summary: crash if I try to view source of IMAP acount mail message with attachment → crash if I try to view source of IMAP acount mail message with attachment

Comment 1

17 years ago
We need the talkback id from the crash or a stacktrace
Keywords: stackneeded
(Reporter)

Comment 2

17 years ago
All craches occurs on messages in MIME format with attached files encoded in
base64. If attachments is uuencoded then everything works just fine.

I can't get talkback id or a stacktrace because when mozilla craches all I get
is message box with "OK","Cancel" buttons. Hitting either of it just closes
mozilla window.

I'm using talkback enabled Installer:
http://ftp.mozilla.org/pub/mozilla/releases/mozilla0.9.2/mozilla-win32-0.9.2-installer.exe

(Reporter)

Comment 3

17 years ago
One more thing. Everything works just fine if I copy such a message to one of
Local folders and try open from there.
can someone send me a message in this form?  (sspitzer@netscape.com)

once I get the crash, I can paste the stack in here (and either fix it or find
the right owner.)

I think signed outlook emails are base64 encoded.

Comment 5

17 years ago
Confirming 2001083106 linux. Crashes every time on every IMAP-Message. If I copy
them to a local folder it works.
I can't give you a TB since TB currently doesn't work on linux. (btw: OS -> All)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 6

17 years ago
I get crashes (using release 0.9.4) if I attempt to download an attachment from
an IMAP mailbox; may be the same problem.  Talkback info: TB35809269E, TB35809200Q

Comment 7

17 years ago
Additional debugging:
Tried to do "view source" on problem message; "view source" did not appear to
work, but did not cause a crash (I got a new, blank window any time I tried to
view source of any message).

Will look for better bug to attach this to or file a new bug.  

Comment 8

17 years ago
cc'ing soem IMAP developers.  Does someone have a message that causes this?
Keywords: nsbeta1

Comment 9

17 years ago
Here's the stack trace from B35809269E

nsCStringKey::nsCStringKey()
nsExternalHelperAppService::AddMimeInfoToCache()
nsOSHelperAppService::GetFromMIMEType()
nsExternalHelperAppService::DoContent()
nsDocumentOpenInfo::DispatchContent()
nsDocumentOpenInfo::OnStartRequest()
nsStreamConverter::OnStartRequest()
nsOnStartRequestEvent0::HandleEvent()
nsStreamListenerEvent0::HandlePLEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xefdc (0x402fbfdc)
libglib-1.2.so.0 + 0x10736 (0x402fd736)
libglib-1.2.so.0 + 0x10d43 (0x402fdd43)
libglib-1.2.so.0 + 0x10eec (0x402fdeec)
libgtk-1.2.so.0 + 0x785d9 (0x402525d9)
nsAppShell::Run()
nsAppShellService::Run()

perhaps the mime type is null?

Comment 10

17 years ago
Anyone have a message that causes this?  It would help in reproducing this.

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+

Updated

17 years ago
Priority: -- → P2

Updated

17 years ago
QA Contact: esther → trix

Comment 11

17 years ago
Is this really a nsbeta1+, P2? If yes, then we need to try and targeted to a
mielstone M1.0 or earlier to make the beta.

Updated

17 years ago
Blocks: 122274
Status: NEW → ASSIGNED
Keywords: nsbeta1+ → nsbeta1-
No longer blocks: 122274

Comment 12

17 years ago
I'm interested in this bug. I tried with attachment encoded in BASE64 several
times and didn't encount the issue. Can anyone send the message that cause the
bug to me? Then I can evaluate it further. Thanks.

If this bug doesn't exist on the trunk, I suggest to close it.

Comment 13

16 years ago
marking wfm
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 14

16 years ago
verified wfm
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.