Closed Bug 903586 Opened 6 years ago Closed 6 years ago

Inspected tag name of tooltip disappears after FindBar open, The tooltip is shifted upward after FindBar open

Categories

(DevTools :: Inspector, defect)

26 Branch
x86_64
Windows 7
defect
Not set

Tracking

(firefox24 unaffected, firefox25+ verified, firefox26+ verified)

VERIFIED FIXED
Firefox 26
Tracking Status
firefox24 --- unaffected
firefox25 + verified
firefox26 + verified

People

(Reporter: alice0775, Assigned: mstange)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot
Steps to Reproduce:
1. Open any web page
2. Right click on a element and choose "Inspect Element"
3. Open FindBar

Actual Results:
Inspected tag name of tooltip disappears.
The tooltip is shifted upward

Expected Results:
Should not

Regression window(fx)
Good:
http://hg.mozilla.org/integration/fx-team/rev/986f7c642b9f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130809074929
Bad:
http://hg.mozilla.org/integration/fx-team/rev/452ca8b779f3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130809110039
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=986f7c642b9f&tochange=452ca8b779f3
Suspected:
452ca8b779f3	Markus Stange — Bug 893446 - Try to avoid moving the page contents when the find bar appears. r=dao
Component: Developer Tools → Developer Tools: Inspector
Attached patch patchSplinter Review
This fixes it and I think it's what was intended all along. Before the findbar set position:relative on .browserContainer, this position:absolute didn't do anything except to provide a reference for the absolute positioning of the .highlighter-nodeinfobar-container children. Now that there is a relatively-positioned ancestor of .highlighter-controls, setting position:absolute on it collapses its width and height and messes up the children position. position:relative lets it keep its size and seems to work correctly.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Attachment #788832 - Flags: review?(dao)
Attachment #788832 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/1d8e3fea9618
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
We need this on 25 if we uplift bug 893446, right?
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #3)
> We need this on 25 if we uplift bug 893446, right?

Yes, we do. Markus, can you request approval for this one too?
Comment on attachment 788832 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 893446
User impact if declined: broken overlays when using the web developer inspector after the findbar has been activated for a tab
Testing completed (on m-c, etc.): 5 days on mozilla-central
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #788832 - Flags: approval-mozilla-aurora?
Attachment #788832 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I can't reproduce this issue with neither one of the Nightly builds from these dates: 2013-08-07, 2013-08-08, 2013-08-09 on a Win 7 64bit machine. 

This seems to be also working with Firefox 25 beta 2.

Does anyone have any thoughts/suggestions? Thanks!
Flags: needinfo?(alice0775)
(In reply to Manuela Muntean [:Manuela] [QA] from comment #7)
> I can't reproduce this issue with neither one of the Nightly builds from
> these dates: 2013-08-07, 2013-08-08, 2013-08-09 on a Win 7 64bit machine. 
> 
> This seems to be also working with Firefox 25 beta 2.
> 
> Does anyone have any thoughts/suggestions? Thanks!
The build on comment #0 is fx-team tinderbox build.
Affected mozilla-central nightly build is
http://hg.mozilla.org/mozilla-central/rev/3d20597e0a07
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130811030225
Flags: needinfo?(alice0775)
Verified as fixed with Firefox 25 beta 2 (build ID: 20130923194050)

Thanks Alice!
QA Contact: manuela.muntean
Verified as fixed with latest Aurora, build ID: 20131007004003
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.