Closed Bug 903680 Opened 7 years ago Closed 7 years ago

[B2G] [Buri] [Unagi] [1.2] [Gallery] Device crashes when switching orientation while in Edit mode

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect, critical)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(blocking-b2g:koi+)

RESOLVED DUPLICATE of bug 912725
blocking-b2g koi+

People

(Reporter: ckreinbring, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [b2g-crash])

Crash Data

Attachments

(1 file)

Attached file Log of device crash
Description:
Attempting to change the device orientation while in the Gallery's edit tool causes the device to crash.

Repro Steps:
1) Update Unagi to Build ID: 20130809040201
2) Launch the Gallery and select a picture.
3) Tap the edit icon (in the middle).
4) Rotate the device (portrait to landscape or vice versa) and observe the device's reaction.

Actual:
The device crashes.

Expected:
The screen changes to the proper orientation with no errors.

Environmental Variables
Build ID: 20130809040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/e33c2011643e
Gaia: c354940fbe112bcf2d90e2a5654ad1824f3a2348
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
See attached logcat logs
Crash ID: bp-81b2b1c2-abbd-45e3-9c57-d7f992130809
See Also: → 831890
It will likely be fixed by bug 858914.
Severity: normal → critical
Crash Signature: [@ nsXPCOMCycleCollectionParticipant::Unroot(void*) ]
Keywords: crash
See Also: → 900012
Whiteboard: [b2g-crash]
(In reply to Scoobidiver from comment #1)
> It will likely be fixed by bug 858914.

Why do you think that?
(In reply to Jeff Muizelaar [:jrmuizel] from comment #2)
> (In reply to Scoobidiver from comment #1)
> > It will likely be fixed by bug 858914.
> Why do you think that?
Based on bug 900012 comment 36.
Smoketest regression because this breaks this test:

[GALLERY] view fullscreen picture, check orientation - verify you can see the picture in full screen with the correct orientation as you change the phone's orientation
Actually I'm wrong - not a smoketest regression - edit isn't included in that test.
Keywords: smoketest
blocking-b2g: --- → koi?
Also repros on the Buri 1.2 mozilla RIL.  Rotating the device while in the Gallery's Edit mode causes the device to crash and reset.

Build ID: 20130904040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ff96bd19c1c
Gaia: b6c5bf1d24230bfed4a8f680e625fa2175001f82
Platform Version: 26.0a1
Summary: [B2G] [Unagi] [1.2] [Gallery] Device crashes when switching orientation while in Edit mode → [B2G] [Buri] [Unagi] [1.2] [Gallery] Device crashes when switching orientation while in Edit mode
This very much looks like a dup of Bug 912725.
GrallocBufferActor trying to call ForgetBuffer on a dead TextureHost, with some WebGL involved, and in particular both bugs happen shortly after the the TextureHost is destroyed (in one case because the app is closed, on the other because switching orientation forces us to re-allocate the textures).
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 912725
No longer blocks: GFXB2G1.2
Duplicate of bug that is koi+'d
blocking-b2g: koi? → koi+
You need to log in before you can comment on or make changes to this bug.