Text selection in XML files doesn't work

RESOLVED FIXED

Status

()

Firefox for Android
Text Selection
RESOLVED FIXED
4 years ago
a year ago

People

(Reporter: Oleg Kuznetsov, Unassigned)

Tracking

23 Branch
All
Android
Points:
---

Firefox Tracking Flags

(firefox23 affected, firefox24 affected, firefox25 affected, firefox26 affected, firefox32 affected, firefox33 affected, firefox34 affected, firefox35 affected)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130624103921

Steps to reproduce:

1) Open any XML, for example: http://maven.apache.org/xsd/maven-4.0.0.xsd
2) Perform a long tap on any part of the document


Actual results:

1) Markers for text selection in document don't appear neither in the XML body, nor in the "This XML file does not appear <...>" message


Expected results:

1) Markers for text selection should appear and allow me to bring the context menu for text copying
(Reporter)

Comment 1

4 years ago
Additional information: I tried it on Firefox 23 and Firefox 24 Beta from Google Play; 
My device is Asus Nexus 7 3G (first generation); Installed OS: Android 4.3 (Baseband version: 1231_0.18.0_0409; Kernel version: 3.1.10-g1e8b3d8 android-build@vpbs1.mtv.corp.google.com #1 Tue Jun 11 23:51:41 PDT 2013; Build Number: JWR66V)
I can reproduce this on Samsung Galaxy Nexus (Android 4.1.1) on the latest Nightly 08/13
I've installed on older build and both text selection and context menu appeared.
Status: UNCONFIRMED → NEW
status-firefox23: --- → affected
status-firefox24: --- → affected
status-firefox25: --- → affected
status-firefox26: --- → affected
Ever confirmed: true

Comment 3

3 years ago
Confirmed Fx 32 on Nexus 7 2012 Android 4.4.4

It means I am unable to copy a (coloured blue but non-clickable) URL from an RSS file.
(It doesn't display RSS files like the desktop version of Fx - bug or by-design?)
Example - the mp3 files here:
http://www.afolksongaday.com/?feed=rss2

Updated

3 years ago
status-firefox32: --- → affected
status-firefox33: --- → affected
status-firefox34: --- → affected
status-firefox35: --- → affected

Updated

3 years ago
Component: General → Text Selection
OS: Linux → Android
Hardware: x86 → ARM
Workarounds and alternative behaviors:

* Subscribe to the feed using the Home Feeds add-on.

https://addons.mozilla.org/en-US/android/addon/home-feeds

* Use view-source to get a highlighted plain-text version of the feed.

view-source:http://www.afolksongaday.com/?feed=rss2

allows me to select text.
Hardware: ARM → All
Pruning some old bugs obviated by new Core/Layout AccessibleCaret implementation, or being no longer observable.

(Please re-open if appropriate.)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

2 years ago
Still able to reproduce. Firefox for Android 43.0 (20151214163750)
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
I'm sorry if I wasn't clear. The new AccessibleCaret feature is currently available in Nightly/46 and (iirc) targeted for release in 47.

Testing in nightly confirms this will be corrected.
(Reporter)

Comment 8

2 years ago
Looks like it was fixed in Firefox for Android 48.0b1 (20160607191837). Not sure why Bugzilla doesn't let me change the flag to Resolved/Fixed (I don't see this combination), so I'm going leave as it is
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.