Requests from BackgroundPageThumbs service show up in devtools panels

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 months ago

People

(Reporter: ttaubert, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Whenever the background thumbnailing service decides to load a page, the network requests, script errors, CSS errors, etc. show up in the devtools panel if it is open.
I'm not sure this is a bug - isn't it by design that all requests made by the browser appear there?  eg, requests in background tabs do too which seems analogous.  FWIW, I agree that all these "background" requests make the devtools panel less useful for many tasks, but while it shows *any* "background" stuff I can't see a reason to exclude the thumbnails.
(In reply to Tim Taubert [:ttaubert] from comment #0)
> Whenever the background thumbnailing service decides to load a page, the
> network requests, script errors, CSS errors, etc. show up in the devtools
> panel if it is open.

Which devtools panel? The console? If they're browser errors, they should show up in the browser console (separate window, error console replacement). If they're browser errors that are showing up in the Web Console from another page, then that's a problem.

Need more details, please. STR?

Updated

5 years ago
Flags: needinfo?(ttaubert)
(Reporter)

Comment 3

5 years ago
Sorry, I can't reproduce that anymore. I just remembered that background thumbs are captured in a separate process so I think it's very unlikely that any stuff from the bg process shows up in the main process devtools.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(ttaubert)
Resolution: --- → INVALID

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.