remove a bogus assertion from ThebesLayerBuilder

RESOLVED FIXED in mozilla26

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: nrc, Assigned: nrc)

Tracking

Trunk
mozilla26
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Created attachment 788871 [details] [diff] [review]
patch

This assertion is bogus. It asserts that we should not have an azure buffer when we have a thebes dest buffer. The situation arises because we start with no texture client, therefore we cannot tell whether it will be safe to use Azure and we ere on the side of caution and say no. Thus we create destBuffer, rather than destDTBuffer. In the process of creating destBuffer, we create a texture host. If that texture host can support Azure, then we fail this assert. But there is nothing wrong. And on the next frame we will get an azure buffer as expected (because in EndPaint we call SetBufferProvider(nullptr) which nulls out mBuffer and mDTBuffer so we will request a DrawTarget.

Please lets kill Thebes here asap.
Attachment #788871 - Flags: review?(matt.woodrow)
Attachment #788871 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/50d2adb2f34d
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
(Assignee)

Updated

5 years ago
Duplicate of this bug: 905772
You need to log in before you can comment on or make changes to this bug.