Closed Bug 904282 Opened 6 years ago Closed 6 years ago

Don't mark atoms during last GC

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26

People

(Reporter: billm, Assigned: billm)

References

Details

Attachments

(1 file)

Right now it looks like we mark interned strings and static strings during the final GC. I don't see any need to do that.
Attached patch atomsSplinter Review
Attachment #789256 - Flags: review?(jcoppeard)
Comment on attachment 789256 [details] [diff] [review]
atoms

Review of attachment 789256 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Attachment #789256 - Flags: review?(jcoppeard) → review+
https://hg.mozilla.org/mozilla-central/rev/2f7112835ad1
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Duplicate of this bug: 905652
You need to log in before you can comment on or make changes to this bug.