Correct sizes for hidden preload browsers are never applied

VERIFIED FIXED in Firefox 24

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: ttaubert, Assigned: ttaubert)

Tracking

({regression, verifyme})

Trunk
Firefox 26
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox24+ verified, firefox25+ verified, firefox26 verified)

Details

Attachments

(2 attachments)

Someone (me) broke the efforts from bug 875257 with bug 881590. Which means that the preloading browsers end up not having the right sizes and we have reflows after docShells have been swapped :(

Nominating for tracking because fixing this should be trivial and we certainly don't want a slow tabopen animation.
Comment on attachment 789596 [details] [diff] [review]
Ensure that sizes for preload browsers are applied correctly

Review of attachment 789596 [details] [diff] [review]:
-----------------------------------------------------------------

Wasn't there supposed to be a test that made sure we didn't regress this?
Attachment #789596 - Flags: review?(jaws) → review+
(In reply to Jared Wein [:jaws] from comment #2)
> Wasn't there supposed to be a test that made sure we didn't regress this?

Yeah, that didn't quite land yet...
https://hg.mozilla.org/mozilla-central/rev/cb1b1f0d16ff
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 26
[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 881590
User impact if declined: Slow and choppy tabopen animation.
Testing completed (on m-c, etc.): Landed on m-c.
Risk to taking this patch (and alternatives if risky): Low risk.
String or IDL/UUID changes made by this patch: None.

Asking for Beta and Aurora approval as this is a really simple fix that vastly improves the tabopen animation, especially on slower machines.
Attachment #790661 - Flags: review+
Attachment #790661 - Flags: approval-mozilla-beta?
Attachment #790661 - Flags: approval-mozilla-aurora?
(In reply to Tim Taubert [:ttaubert] from comment #6)
> Created attachment 790661 [details] [diff] [review]
> Ensure that sizes for preload browsers are applied correctly (for beta and
> aurora)
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): bug 881590
> User impact if declined: Slow and choppy tabopen animation.
> Testing completed (on m-c, etc.): Landed on m-c.
> Risk to taking this patch (and alternatives if risky): Low risk.
> String or IDL/UUID changes made by this patch: None.
> 
> Asking for Beta and Aurora approval as this is a really simple fix that
> vastly improves the tabopen animation, especially on slower machines.

Tim, is there a test case for this patch ? Also do we need any help from QA with verification by performing any manual testing for any test cases you may have in mind ?
(In reply to bhavana bajaj [:bajaj] from comment #7)
> Tim, is there a test case for this patch ? Also do we need any help from QA
> with verification by performing any manual testing for any test cases you
> may have in mind ?

That's unfortunately bug 876218. I started to work on this a few moons ago but was held up by try issues, iirc. Verifying this is a little tricky, you would need to write some code for it and run that. I could do that, though once it landed on beta/aurora. Or is that maybe not the same as somebody doing it from the QA team? :)
(In reply to Tim Taubert [:ttaubert] from comment #8)
> (In reply to bhavana bajaj [:bajaj] from comment #7)
> > Tim, is there a test case for this patch ? Also do we need any help from QA
> > with verification by performing any manual testing for any test cases you
> > may have in mind ?
> 
> That's unfortunately bug 876218. I started to work on this a few moons ago
> but was held up by try issues, iirc. Verifying this is a little tricky, you
> would need to write some code for it and run that. I could do that, though
> once it landed on beta/aurora. 

That will be very helpful :) thanks !

>Or is that maybe not the same as somebody
> doing it from the QA team? :)
Comment on attachment 790661 [details] [diff] [review]
Ensure that sizes for preload browsers are applied correctly (for beta and aurora)

Approving given this is low risk FX25 regression and we are still in early beta's.Tim to help with verification once this lands.
Attachment #790661 - Flags: approval-mozilla-beta?
Attachment #790661 - Flags: approval-mozilla-beta+
Attachment #790661 - Flags: approval-mozilla-aurora?
Attachment #790661 - Flags: approval-mozilla-aurora+
Keywords: verifyme
(In reply to Tim Taubert [:ttaubert] from comment #8)
> Verifying this is a little tricky, you would need to write some code for it and run that. I could do >that, though once it landed on beta/aurora. Or is that maybe not the same as somebody
> doing it from the QA team? :)

Hi Tim! Are there any news/updates regarding this? Is there anything QA can help with here? Thanks!
Flags: needinfo?(ttaubert)
Visually this looks smooth and correct on 24beta10 and Aurora and Nightly builds of 20130913.
Confirmed that an old beta version had the wrong sizes. After updating the preload browsers have the correct dimensions.
Flags: needinfo?(ttaubert)
You need to log in before you can comment on or make changes to this bug.