Closed Bug 904760 Opened 6 years ago Closed 6 years ago

Quality of video calls on FxAndroid --> FxAndroid calls through apprtc can occasionally be unusable

Categories

(Core :: WebRTC: Audio/Video, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 904754

People

(Reporter: jsmith, Unassigned)

References

Details

(Keywords: perf, Whiteboard: [WebRTC][android-webrtc+])

The signoff Fx24 testing for WebRTC FxAndroid calls in https://etherpad.mozilla.org/webrtc-testing revealed that the video/audio streaming performance for FxAndroid calls can vary from being usable to unusable. In the unusable case, the video frames change so slowly that each frame changes on a per second basis, making the call almost unusable. To reproduce this, try doing a couple of sessions of FxAndroid to FxAndroid remote calls from a cold start. You'll eventually hit a couple of cases of calls that have poor video streaming quality.

Note - for the audio issue, see bug 904754.
Tracking nom for the same reasons as https://bugzilla.mozilla.org/show_bug.cgi?id=904754#c1.
tracking-fennec: --- → ?
Whiteboard: [WebRTC][android-webrtc?]
Whiteboard: [WebRTC][android-webrtc?] → [WebRTC]
Working on getting a video here, but did some digging here. What's happening here is we're getting intermittent freezes during video calls that last up to 15 seconds, rendering the call unusable.
Spoke with tchung about this - Mobile QA views this as a blocker to prevent shipping WebRTC on Fx24 for Android. The minimal acceptance criteria for ship was that:

* Bare minimum: 1 min call works reliably over video/audio over multiple runs
* Recommended: 5 min call works reliably over video/audio over multiple runs

We aren't hitting the bare minimum due to this bug.
Whiteboard: [WebRTC] → [WebRTC][android-webrtc+]
Point of comparison also:

On Mozilla wifi - If I do a video --> video call on FxAndroid nightly on Mozilla wifi, the video comes in smooth with low latency with occasional small freezes if I walk around.

On Mozilla wifi - If I do a video & audio --> video & audio call on FxAndroid nightly on Mozilla wifi, the video instead hits the exact issues in this bug.

Sounds like the problem that's happening here like what was discussed over in bug 904754 is when video & audio are put together.
(In reply to Randell Jesup [:jesup] from comment #5)
> http://www.kandroid.org/online-pdk/guide/tcpdump.html

Note - the devices involved here under test are non-rooted devices. Do we have anything available for non-rooted devices?
See Also: → 904754
Keywords: perf
The root cause appears to be coming out to be similar to bug 904754, so I'm duping over there to keep communication on one bug.
Status: NEW → RESOLVED
tracking-fennec: ? → ---
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 904754
No longer blocks: android-webrtc
You need to log in before you can comment on or make changes to this bug.